Trouble typing in RVIZ

Hi all,

I am using a MacBook Pro and accessing RVIZ on a website provided by the Construct. However, I often cannot type in RVIZ using the touchpad and even a mouse.
Can somebody provide any advice on what I could do to solve this issue?
Thank you in advance.


Could you please clarify what you are experiencing? Are you not supposed to type with the keyboard? Did you mean that you mouse is not working in Rviz?

Hi, thank you for the response.

I cannot select the text to edit in the left panel (Displays) using the touchpad and mouse. (This may be because I cannot type in RVIZ)
I cannot type in the RVIZ using the keyboard in any way. This is a problem when I want to save the configuration of the file but I cannot because I cannot type there. The only method I could “type” is by copying and pasting text by right-clicking.

Generally you should be able to type where you are supposed to, and I see you are using a supported browser - Chrome.

Can you try Firefox?

Also, could you please tell me the Exercise or Example you are taking, and the course and unit you are on?


I have not tried FireFox but I have tried Safari, yet the same issue remains.
I realized that this issue frequently occurs when taking the beginner courses such as ROS in 5 days, but I only occasionally have this issue in the ROS control and navigation in 5 days courses.


  • Please try Firefox and let us know.
  • Please try a specific course, and tell us the unit/exercise where this is happening specifically. If possible, please record a screencast.
  • If possible try it on a different PC>

There are things that may happen that are specific to a given PC; we would get a lot of complaints if it was a general case. So we need some specific information to figure out what is happening.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.