404 Not Found Error on Web Video Server Page - Developing Web Interfaces for ROS Unit 5

I am doing Unit 5 of the Web Interfaces Course but cannot seem to get the web_video_server page to load, I am just getting a 404 error on the page:

The web_video_server seems to be running and catching the request but I still get the 404:

user:~$ rosrun web_video_server web_video_server _port:=11315
[ INFO] [1609243325.491150324]: Waiting For connections on
[ INFO] [1609243329.806424744, 2188.800000000]: Handling Request: /cameras/

I did get this error the first time I tried to start it (not sure if this is relevant):

user:~$ rosrun web_video_server web_video_server _port:=11315
[ERROR] [1609242751.008068952]: Exception when creating the web server!
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error>>'
  what():  bind: Address already in use
Aborted (core dumped)

Hello @ryanf369fd411f1943c8,

This is due to an outdated instruction in the notebook, it will be updated.

Thanks for sharing the error, we have solved in previous posts, please check here: 404 Not Found nginx/1.14.0 (Ubuntu)

You should be able to access the link as following:

Please, let me know if that works for you


Hi @marco.nc.arruda, thanks for the quick reply. Apologies, I missed the previous post on my quick search of the forum.

I think there’s an error in your URL. Using this style from the other answer you linked worked:



1 Like

You’re right! Just changed the URL to be in the correct format!

Great it worked for you!

Best regards!