7.5 Actions Quiz, Error while creating custom Interface

Hello, I am constantly getting an error while doing “colcon build --packages-select actions_quiz_msg” , please help me if you have any solution for this error…Thanks in advance





Hi @siddhantdiwaker.sd! I’m not an expert on this so just throwing suggestions around. Did you forget to add the required dependencies to your package.xml?



Thanks for your reply, but still it doesn’t work, I am getting the same error…

Throwing out another suggestion:

Build Clean: Sometimes, build issues can occur due to remnants of previous build attempts, especially if building on a new machine. Try cleaning the build directory before building the package again. You can do this by running the following command from your ROS2 workspace root directory (e.g. ros2_ws): sudo rm -r build install log . After that, try to build the package again: colcon build to build ALL packages

already did, nothing’s working

Hello @ernest.cheong.ec
Thanks for your reply, I have tried it, but it doesn’t work…

Hi @siddhantdiwaker.sd unfortunately I can’t spot what else might be the issue from the screenshots you sent and from my experience and knowledge.

If you haven’t already, a good problem solving technique is to google (or chatgpt) the error that you are getting, specifying your circumstances and the key things you did to get to this point.

Perhaps you could also backtrack and go back to the point in time when things worked? What was different then versus now?

Sorry for not having a specific solution- I understand it must be frustrating.

A fellow learner

1 Like

Hi @ernest.cheong.ec
I have literally tried everything possible from ChatGPT to Google, but cannot find the solution, I have even tried to rebuild the whole package write the code again and tried “colcon building” it again, but still the same error occurs…

And yes, it is really really frustrating, but now I am prone to it, I just admit that " It will come no matter what I do " so its fine for me…

Sweet regards.

Hi @siddhantdiwaker.sd,
Can you show me your Distance.action file ?
Also why do you name you folder distance_as to store your action?

Did you try to add rclcpp_action in your dependencies ?

find_package(rclcpp_action REQUIRED)


<depend> rclcpp_action </depend>

Also try to add in your package.xml:


Best regards,
Enzo Ghisoni

Usually this happened because you overlooked something in the process. Please carefully review the material on creating custom messages to see what you might have missed.

When creating packages, adding the dependencies during creation is better than having to edit CMakeLists.txt and package.xml later because this is error-prone.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.