7- Project: Action client not connected: rb1/gripper_controller/follow_joint_trajectory

HI All
Im having trouble adapting the simple_grasping project to the new rb1_mico robot in the project…

I thought i had made all the required modifications. But im guessing ive missed something

my ros_conrtollers.yaml looks like

  - name: rb1/mico_arm_controller
    action_ns: follow_joint_trajectory
    default: True
    type: FollowJointTrajectory
      - mico_joint_1
      - mico_joint_2
      - mico_joint_3
      - mico_joint_4
      - mico_joint_5
      - mico_joint_6
  - name: rb1/gripper_controller
    action_ns: follow_joint_trajectory
    type: GripperCommand
    default: True
      - mico_joint_finger_1
      - mico_joint_finger_2
      - mico_joint_finger_3

And when i do a rostopic list i do see


However whn i try to run pick_and_place.py
i get

[ INFO] [1630294446.426853426, 1174.931000000]: Starting planning scene monitor
[ INFO] [1630294446.461129761, 1174.934000000]: Listening to '/move_group/monitored_planning_scene'
[ INFO] [1630294446.890594728, 1175.164000000]: waitForService: Service [/get_planning_scene] has not been advertised, waiting...
[ INFO] [1630294451.899910732, 1177.458000000]: Failed to call service get_planning_scene, have you launched move_group or called psm.providePlanningSceneService()?
[ INFO] [1630294451.900072003, 1177.458000000]: Constructing new MoveGroup connection for group 'arm' in namespace ''
[ WARN] [1630294453.866508653, 1178.160000000]: Waiting for rb1/gripper_controller/follow_joint_trajectory to come up
[ WARN] [1630294471.314730441, 1184.162000000]: Waiting for rb1/gripper_controller/follow_joint_trajectory to come up
[ERROR] [1630294481.934683522, 1186.917000000]: Unable to connect to move_group action server 'move_group' within allotted time (30s)
[ INFO] [1630294481.937171155, 1186.917000000]: Constructing new MoveGroup connection for group 'arm' in namespace ''
[ERROR] [1630294491.978916526, 1190.163000000]: Action client not connected: rb1/gripper_controller/follow_joint_trajectory
[ INFO] [1630294492.093462340, 1190.187000000]: Returned 1 controllers in list

Up to this point everything has worked correctly I can see the table and cube in the point cloud and i can see that it can find pickable objects.
I suspect we need to change shape_grasp_planner.py because the gripper is different

ShapeGraspPlanner::ShapeGraspPlanner(ros::NodeHandle &nh) {
   * Gripper model is based on having two fingers, and assumes
   * that the robot is using the moveit_simple_controller_manager
   * gripper interface, with "parallel" parameter set to true.

But its not at all obvious to me how?

Hello @darthShana ,

We are working on modifying some things in this project in order to make it more accessible to students. I suggest you move on to other courses in the meantime. I’ll let you know once we have updated it.

Hello @darthShana ,

My sincere apologies for taking so long to solve this issue. It was a complex one and our resources are limited as a small company. Finally, we’ve taken the option of completely changing the final project. Feel free to check the new project and please let me know if you need anything.

Hi Alberto!
Is this problem solved as i am having the problem as ur3 did noting in gazebo when run demo.launch, in part 1 of final project

Hello @misbahsuhail123 ,

The demo.launch file generated by Moveit is not supposed to control the simulated robot. This launch file is only for testing the setup in RViz. To control the Gazebo robot you need to create a new launch file as explained in Unit 4 - Motion Planning using Graphical Interfaces Part 2

This topic was automatically closed after 2 days. New replies are no longer allowed.