Action quiz: Drone did not take off


The evaluation of my actions quiz said that “the drone did not take off”. When I tested it before hand it worked. Could you please have a look on my solution?

Best regards

Hi Felix,

This can happen is the drone was not at rest before you started the quiz. Could you try resubmitting again, making sure than nothing is running in any of the terminals and that the drone is landed (you can just use the reload simulation button, one of the buttons on the simulation window)?

Hi bayodesegun,

I have the same issue and even when reloading the simulation it is not working

@gabriel.ballet @felix.conrad010

While taking the Quiz, did the drone take off and then land as the grader ran? This should happen and I just tested again.

Could you please check that you have created every file as specified, that your server accepts the expected takeoff and land keywords, and that all other instructions of the Quiz are executed?

The first time I tried it did take off but it didn’t land so I tried a second time and then it didn’t take off at all

My bad the name of the action was wrong

1 Like


I tried again after revisiting the website and now it worked.

Problem is resolved, why I cannot say.

Best regards

1 Like

Hi, I’m currently facing the same issue with drone takeoff as felix, with the action server responding successfully to manual action server calls, but without any activity in the quiz. I’ve used 3 out of my 5 submissions so far.

My hunch lies with the topic name. Could I verify what the structure of the topic looks like? I currently have it set to /Ardrone/, and I’m wondering if it should be /action_custom_msg_as/ instead.

I took the plunge and decided to try again. Turns out I made the mistake of initialising the server object with the wrong action name, so yes, the action name is “/action_custom_msg_as”, so it will look like “/action_custom_msg_as/” in rostopic list

1 Like