[Bug] rospackage missing problem

This is an error report.

Screenshot of the error

Error details

I have done all the things as indicated but the problem has not been solved. It can't detect the new created package. I've tried many times but didn't work. I bet there's somthing problem with this program.

Hi @IROS ,

Welcome to this Community!

Try to restart the simulation and the terminal and re-run your package.
Restart Simulation: Click on the first circular arrow mark from the left side on the simulation window top-right corner buttons.
Restart Terminal: Click on the circular arrow mark on the right end of the terminal tab.
Once Simulation and Terminal have been restarted, you can then launch your program again.

Please let me know if this did not solve your problem and you still have issues.


1 Like

Please try:

# recompile the workspace
cd ~/catkin_ws
rm -rf build/ devel/

# Source the workspace
source devel/setup.bash

# Trigger packages detection
rospack profile

You save my time! :grinning: :grin:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.