Cannot connect robots in lab


I have tried to connect robots in lab for 4 months, but none of them worked. I can connect with camera and even move robots with joystick, but when I check rostopic list and rviz, they always show “cannot communicate with master”. I have taken the advices from ppl to change different computers, shutdown anti-virus software and so on, but nothing helped. I have changed 4 computers, and I cannot still believe that it is my problem…

Please, I need an advisor to see what is happening when I am in a booking. How can I contact technicist in TheConstruct? Keep being like this is upset…

Jialei Li


I’m sorry you are having these issues.

If you haven’t been able to connect for 4 months, then this issue must be particular to you.

Once you are connected and can move the robot with the joystick, then you should not have issues with master communication, since that joystick is working through that master.

If you want, please email me at so we can investigate your issue further.

Thank you