Cannot connect with real robot (Joystick panel spinning)


I have tried to connect to the real robot today to test my program for the part 1 of the course. But I saw that the joystick panel does not connect. I was waiting around 10 minutes and the no change. I tried to connect with the robot again but I had the same issues again.

I also had another issue: when I even run the command below:
rostopic list

I got an error: Unable to communicate with master!

anyone knows what should I do?


Today I booked it again. The joystick is working but the rostopic list still give me the error!!!

Unable to communicate with master!

Hi @h90.rezaeifar, I will look into this. If the joystick appears, then that usually means that you are connected to the robot. Did you try to move it around?

As for the master communication issue, I suspect that you attempted this when you where not yet connected.

Nevertheless, I will check into this issue myself and report back to you.

Thank you

Just to let you know that I tried the robot connection and it went well. Make sure that when you do rostopic list, the connection to the robot is established (a green dot should appear on the robot icon at the bottom menu bar.

Thank you for your reply.

I finished the project of the course but I still cannot test it on real robot since it cannot communicate with the real robot. The joystick is working well and I moved the robot with joystick but when I want to find the topics through rostopic list, it says “Unable to communicate with master!”. My firewall is off and I checked the add blockers as well and all of them are disabled.

Even I used the keyboard method to check if anything wrong with my codes:
roslaunch turtlebot3_teleop turtlebot3_teleop_key.launch
but although the joystick was working the program did not communicate with the real robot as you can see in the video below.

Please let me know if I need to check other things!