Can't run roscore on my local machine (robot) after installing the Real Robot Lab client

Hello to everyone,

I was trying to connect to my real robot in one of my rosjects and i executed the indicated command in my robot to install RRL client. After that i followed the instructions of running ‘source ~/.bashrc’ and when i run roscore i got the following error:
"RLException: Unable to contact my own server at [http://master:36619/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself. Please check
for errors by running:

ping master

For more tips, please see

The traceback for the exception was written to the log file"

Before installing RRL client my roscore run without any problem. Can someone help me?

Thanks in advance

Hello @Jaime795 ,

Could you check the content of the file /etc/hosts? You should have defined there the alias master for your local computer.

What about the .bashrc? The insllation should also append some instructions at the end of this file

Thanks for your answer, sorry for not replying before, during the week I don’t have any time to spend on my projects. I’ve checked both files:

  • In my .bashrc file I have the new vairbales which were added after the installation but I don’t see any instructions.

  • In my /etc/hosts files I have added the master host but i don’t know if i did it properly.

Know when I’m trying to run ruscore i get the following:

Hello did you have time ro review my answer? I’m still stuck at this point.

Thanks in advance and Best regards.

Hi @Jaime795 ,

Thank you for your patience. This error may occur mostly due to firewall restrictions.
I’ve just reproduced it blocking UDP ports using ufw, a common firewall in Linux.

Could you check if you have any firewall running in your raspberry?
After disabling it, remember to restart the theconstruct.rll service and source the workspace again.


I’ve been all the week on a job trip so I did not have access to my Rpi until today, that’s why I did not answer before.

Finally I have been able to run roscore after installing theconstruct.rll i needed to update some packages before. I have done what it is stated in the video remote robot with ROSDS - YouTube and it looks like I’m connected to the robot (see image below) however when I open a terminal in my project and type rostopic list to check if i can see the topics running in my robot y get an error message “ERROR: Unable to communicate with master!”

I don’t know what could be happening, the instructions of the video are really straight forward but it is clear that something is not working as it should be.

Hi @Jaime795 ,

Could you get the value in the browser file /etc/hosts?

It is also helpful to try ping6 master, it should reach the robot’s IP like that.

In the robot files, .bashrc should enable ROSIPV6 mode, could you show the last lines of your robot’s .bashrc and /etc/hosts as well?


Hi ,

The /etc/hosts content is the following: master
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters raspberrypi

0000:0000:0000:0000:0000:0000:0000:0001 master # managed by Husarnet

The ROSIPV6 is enabled, the content of the .bashrc file is the following:

export ROS_IPV6=on
export ROS_MASTER_URI=http://master:11311
export ROS_HOSTNAME=master

when i run the command ping6 master i get the following:

Hope that this is enough, if you need any other thing please tell me.

Thank you very much and Best Regards,
Jaime R.

Hi @Jaime795 ,

Thank you for the details, yet we don’t have the information about firewalls.
Could you check if there is any blocking rules in your robox linux?
You can check with the command

sudo ufw status

If the robot does not have any firewall rules, it is important to make sure the network it is connected also allows it to connect to external networks. It uses to happen behing universities or some companies networks

Hi @Jaime795,

the master host that should have been added automatically to /etc/hosts should be an IPV6 address, something like:

fc34:1123:4456:7789:1000:1111:1212:1313 master # managed by Husarnet

Since that does not exist in your /etc/hosts file, then it is very likely that you have a firewall blocking Husarnet.

Hi and @ralves,

Sorry for the late replay, but i am coming with really good news. After upgrading some packages and running again the command to install everything related with “The construct” the /etc/hosts file got updated correctly and i am able to connect to my robot from my rosject.

Thanks a lot for your effort.

Best regards,

Jaime R.