Catkin_make error in /opt/ros/kinetic/share/catkin/cmake/safe_execute_process

Hi can anyone help me fix this issue

CMake Error at /opt/ros/kinetic/share/catkin/cmake/safe_execute_process.cmake:11 (message):
  "/usr/bin/python2" "/usr/bin/empy" "--raw-errors" "-F"
  "/home/user/catkin_ws/build/catkin_generated/" "-o"
  "/opt/ros/kinetic/share/catkin/cmake/em/order_packages.cmake.em") returned
  error code 1
Call Stack (most recent call first):
  /opt/ros/kinetic/share/catkin/cmake/em_expand.cmake:25 (safe_execute_process)
  /opt/ros/kinetic/share/catkin/cmake/catkin_workspace.cmake:35 (em_expand)
  CMakeLists.txt:67 (catkin_workspace)

-- Configuring incomplete, errors occurred!
See also "/home/user/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/user/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed

i have tried removing catking_ws/ rm -fr build/ devel/
and when i run catkin_make again it comes up with this error, this is at axercise 9
should i copy pasete the:

/opt/ros/kinetic/share/catkin/cmake/em_expand.cmake:25 (safe_execute_process)
  /opt/ros/kinetic/share/catkin/cmake/catkin_workspace.cmake:35 (em_expand)
  CMakeLists.txt:67 (catkin_workspace)

i would normally try and build from source but i am not sure if i it is wise to delete the build and devel directory from the main build? i am really stuck because i cannot use the workspace, or is there any other way to reset the system?
i have no idea what i have done

ok i managed to fix this
i opend a ROS python course, and waited for everything to load

then i went back to ros course begening course and waited to load everything, and then catkin_make started working again.
i tried logging out and back in before but it didnt work , maybe i was not loged out for long enaugh

1 Like