"Connecting to virtual computer" in the simulation window hang or frozen

“Connecting to virtual computer” in the simulation window hang or frozen.

Tried switching to other units within the course (ROS for Industrial Robots 101) to no avail.
Tried switching to other course (ROS Manipulation in 5 days) and to units within that course, to no avail.

I registered today for a month-worth and have to use every time I have during the weekends so this time (weekend) is quite critical for me - I didn’t know I’ll get stuck as soon as this part (note: I have taken courses here before and I just activate/deactivate depending on my schedule).

I hope someone replies soon.

Thank you very much.

Hey @maggie.roxas,

Sorry about the problem! And sorry that I missed I somehow missed this question. Also, welcome to the Community!

Could you please try another connection or ask your network admins (if any) to be sure? It seems that for this connection ws and wss connections are being blocked, as I see that nothing was loaded. These connections (web socket) are needed in addition to http and https connections for the environment to work.