Course: ROS Deep Learning With Tensor Flow 101, unit: 1


In the last step I execute the command:

roslaunch tf_unit1_pkg start_image_recognition.launch

I have an error:

ERROR: Unable to start node type [tf_unit1_pkg /]: Unable to locate node [] in package [tf_unit1_pkg]

What do I do with it?

Please check that the python script has executable permissions:


And change them if necessary:

chmod +x

Please let us know if that solved the issue.
It could also be that you didn’t place it there in that package. Please check these issues firts just in case ;).

Hey @piotr.miskiewicz.priv, how are you doing? Great to see that you are participating in the ROS Deep learning course, I think it is pretty awesome. SO yeah I guess it was due to the reason that the image_recognition script in the src folder might not have the required permission. You could check it out by executing " ls -la " command in the src folder, and then executing chmod +x I would recommend that you go through the unit 1 of ROS basics in 5 days course, you may find a better reference to this problem over there. Let me know if the problem still persists, I will be more then happy to help you through it. Cheers. :slight_smile:

chmod +x solved the problem :slight_smile:
Thank You!

1 Like