Hi guys @staff I started to follow a free course of ROS-AUTOWARE (15 weeks). it seems to be a very nice course with the best experts of the area…this is good but also a problem. In the first class they show us just the last lines of the installation of ADE (Awesome development environment)…and not all the complete installation of Nvidia Driver and CUDA Docker…toolkits…
I lost all weekend trying to accomplish with all the steps from this tutorial they created in link description of this video:
However I got some errors…
My linux is 18.04 ubuntu
NVIDIA GTX 1050 ( I have checked and is compatible with an efficience of 6.0)

There is also a step that during the instalation guide they say me follow recommended steps if I have the CUDA toolkit version X.Y or different from X.Y how can I know about this info I have already issued in terminal the command to get the Cuda version installed and the toolkit…and I received that is 9.0 and other commands say that is 11.0 …this is so confuse

I installed the toolbox - the cuda…however the ade returns me the following error when I try access it:
FileNotFoundError: [Errno 2] No such file or directory: ‘docker’: ‘docker’
[3606] Failed to execute script pyinstaller-entry-point

Well if some of you guys had already installed this and could assist me, I would really be grateful! Thanks!

Hi Marcus I did the installation of the ADE environment and also got a problem with the Nvidia Driver, but I remember having solved it easily by getting Ubuntu 18.04 and installing some missing Ubuntu docker packages. I cannot tell you which ones because I don’t remember…

CUDA installation is always a problem. What I would recommend you is that you make sure your base system is working with Nvidia Drivers just for screen management (install Nvidia drivers for your screen and graphic card, do not install CUDA). Once you have that installed and you can launch nvidia-settings command in your terminal, then move to ADE docker.

Install ADE docker as in the Autoware instructions. Then, inside that docker install CUDA, not in your base system. That is what I did to make it work.

Hope this helps

1 Like

Hi @rickt thanks very much. After some patience and repairing some errors…I have done…however I have 2 problems…always when I try to access the ade through “Ade enter” command I get an error of connection

Which I also need issue the commands present in this site to fix…but it is very boring to issue this every time I open a new window…and if some script being running in ade then it is impossible to access it through other shell…did you have this problem? I have written then in my bahsrc these commands in order to avod issue then every time…but it is very annoying see and request mz password everytime when a new shell is opened

The other error was following the tutorial from first class to see the lidar velodyne data…the first line I iusse the first command to broadcast the dowloaded data pcap…and terminal returns me nothing (how can I be sure if the data is being or not broadcasted? the terminal just remains opened…
after this in other shell I launch rviz to see the data (second command from tutorial) and receive this error you can see below

Do you which could be the reasons for this error and how to repair?

@rickt I have found this answer
however I tried the commands and did not work
I have installed then CUDA and Nvidia driver in my base systems too after this…and I followed all that extensible mandatory and recommended and optional installation steps from Nvidia -driver - docker - cuda webiste… all of them worked with success…all the steps passed…the execution of deviceQuery and also the other one to check compatibilities between driver-my Nvidia Graphic card-distro-etc…
So I have no more ideas about what is going on…seem an rviz issue…that if I am not wrong sometimes I had this similar error in ROS1 and needed to reinstall ros or some speficics ROS libraries if I am not wrong…to enable rviz work… Do you have some suggestion looking this image error from where could I start looking for?

I solved doing this: I solved this just changing the driver ( for some reason my driver after doing the tutorials was set to Nvidia driver 450 (open source) and the correct was set the driver in ubuntu software & updates - additional drivers - to Nvidia driver 440 (Propetary). Before this I have lost days coniguring new drivers…new dockers tools…and tests to check the compatibility between docker 19.03 my Nvidia drivers and see if they were coupled correct in order to enable the GPUS for the images written over the containers…and they were correct. I suggest this tutorial for who wishes and need to configure this…

Also for who is trying to run the lidar simulation is needed to change the following lines…they seem to be wrong…
3- ros2 run point_cloud_filter_transform_nodes point_cloud_filter_transform_node_exe --model vlp16 __ns:=/lidar_front __params:=/opt/AutowareAuto/share/point_cloud_filter_transform_nodes/param/vlp16_sim_lexus_filter_transform.param.yaml __node:=filter_transform_vlp16_front points_filtered:=/perception/points_in

5 - ros2 run point_cloud_filter_transform_nodes point_cloud_filter_transform_node_exe __ns:=/lidar_rear __params:=/opt/AutowareAuto/share/point_cloud_filter_transform_nodes/param/vlp16_sim_lexus_filter_transform.param.yaml __node:=filter_transform_vlp16_front --remap points_in:=/lidar_rear/points_raw

7 - ros2 run euclidean_cluster_nodes euclidean_cluster_node_exe __params:=/opt/AutowareAuto/share/autoware_auto_avp_demo/param/euclidean_cluster.param.yaml --remap points_in:=/points_nonground

I do not know why in line 5 need to change for rear lidar …does not make sense but the error told this change is necessary…regariding the line 3 and 7 I do not know how it worked in the video becuase for me did not work… I needed to compare with this tutorial (very similar) to perform the changes in order do not have error in terminal. However the last part of gray ground and boundig box objects…unfortunately I did not have success…no idea why but the correct topics did not appear for me in rviz…the topic filtered point cloud of lidar…the second one appeared…