[ERROR] [1588286007.343230]: Current /drone/down_camera/image_raw not ready yet, retrying for getting down_camera_rgb_image_raw

I am using a script (appended to the end of this post) to setup my workspace on my Ubuntu18.04. After setting everything up I ran the following lines:

Terminal 1: roslaunch my_parrotdrone_openai_example start_training_v2.launch
Terminal 2: rosrun sjtu_drone start_gui

However I’m receiving the error:
[ERROR] [1588286007.343230]: Current /drone/down_camera/image_raw not ready yet, retrying for getting down_camera_rgb_image_raw

When doing a rostopic list, I only have the following /drone related topics available:


When looking at the source code, it appears there are a lot of missing camera topics.

When I run different non-openai launch file, i.e., roslaunch sjtu_drone contest.launch, all topics are available.

How do I fix the missing-topic issue?

Setup Script:


DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" >/dev/null 2>&1 && pwd )"

# Get Base Packages
mkdir -p ~/simulation_ws/src
cd ~/simulation_ws/src
git clone -b version2 https://bitbucket.org/theconstructcore/openai_ros.git
git clone -b version2 https://bitbucket.org/theconstructcore/openai_examples_projects.git
git clone -b kinetic-gazebo9 https://bitbucket.org/theconstructcore/parrot_ardrone.git
sed -i "s/user/$USER/g" ~/simulation_ws/src/openai_examples_projects/my_parrotdrone_openai_example/config/*v2.yaml

# Install Dependencies
# sudo rosdep init # run this line if first time running
rosdep update
rosdep install --from-paths . -i

# Build
cd ~/simulation_ws
source devel/setup.bash
rospack profile

cd $DIR

Solved: Issue was due to running roslaunch my_parrotdrone_openai_example start_training_v2.launch in a ssh terminal rather than from the VM itself. The full list of ROS topics becomes available when using terminal within VM.

New Issue: When running rosrun sjtu_drone start_gui or gzserver the VM display goes black. I believe it is an issue with the my_parrotdrone_openai_example package as this does not occur with roslaunch drone_construct main.launch and rosrun sjtu_drone start_gui.

1 Like

New Issue Fixed! Steps:

  1. In parrotdrone_goto.py (task env), change the ROSLauncher line so it’s:
    ROSLauncher(rospackage_name="sjtu_drone", launch_file_name="contest.launch", ros_ws_abspath=ros_ws_abspath)

  2. In parrotdrone_env.py (robot env), comment out the ROSLauncher() line.

1 Like