ERROR Exercise 4.3 - Not possible publish in Topic move_base/ goal

Hi experts. I am trying to publish a goal destination for the husky robot using the terminal through rostopic pub “topic”. I have followed the instructions to publish a goal for the move_base node ( use the terminal window wide open, etc). However I receive the following message in the terminal which the move_base main node is working:

“[ERROR] [1581952377.821706001, 2037.991000000]: The goal pose passed to this planner must be in the map frame. It is instead in the frame”

The robot does not move in Rviz. Using echo in “status” topic and “feedback” topic is possible to see that the message is “pseudo-being published” because they are infinititly reading returning information…but never reaches the goal. Could you please give a feedback about what is going on? Because it is just working with 2D nav goal graphical icon in Rviz, but not through command line.
Thanks in advance

As the error says, you seem to be publishing the goal message in the wrong frame. Perhaps completely omitting the frame. Adjust your command accordingly. If it doesnt work, please post what exactly you typed in the terminal.


Thanks Simon. I was in a hurry and did’n pay attention the required inputs.
However I am still in doubt how this msg architecture works. It seems is mandatory put values for the orientation for the robot walk, not just position (maybe becuase the spot is behind or in the robot side…). But the move also seems disordered, I can’t understand if the robot is walking linear and later angular, or if it use the both degree of freedom in the same time to displace. ??
And the quaternion values are pretty different from Euler right? Is there an equivalent table to understand the conversion? I think I will look on internet.
But this command is to send a goal spot. So it should work if my input be just a X,Y coordinates in cartesian plan right? Why it is required to send Quaternion values to work properly? If I don’t use, then comes:
: ERROR] [1581956608.186581030, 624.431000000]: Quaternion has length close to zero… discarding as navigation goal

Maybe I am confusing these goal msg commands with cmd_vel commands. It is not much clear in my head.

What a message sends and how that message is used in your code are two different things.
here you can investigate the structure of the message. The position is pretty self explanatory, it is simply the x,y, z coordinates relative to your frame. The orientation in quaternion is a standard vektor (length 1) expressed in x,y, z and then the rotation around that vector expressed as w. Whether your code needs the orientation or not, I cannot tell you. If you want to convert Euler to Quaternion and vice versa, use the tf library.

1 Like

Hi indeed Simon is right but i still have the same issue.

Here is what i did.
I echoed the goal topic and obtained 3 different points coordinates that i got with “Rviz 2D Nav Goal” (see following picture).

Then from the shell i tried to emulate the same same behaviour by publishing into the goal topic.

In other words i try to go to point A (approx)

but i get that i m outside of the frame ? why ? I’m issuing the same command as Rviz

Why is this due?


so the mistake was not putting the keyword ‘map’ in frame_id. (The devil is always in the details :-))

Sorry for unnecessary post but i think this thread can be useful for other learners :-).




cool!!! sorry for don’t reply because I have solved and forgot to put here!