Error Package not found in ROS Basics in 5 days

In Unit 4, I’ve create the directory topics_quiz, the launch file and py file but get an error saying the pakage is not found when i try to launch it
I did a catkin_make and source devel/setup.bash
I also tried a rm -ref build/ devel/ and did again catkin_make + source
Still having the same issue

Thank you for your help

Hi Pete
I resolved in this way
user:~/catkin_ws$ catkin_make --only-pkg-with-deps topics_quiz

1 Like

Thank you saxosun
Unfortunately I’m still getting the same error with this command
Packages “topics_quiz” not found in the workspace

I’m having the same issue with the project in the ros dev studio
how can i contact an admin for help?

Hey Pete,

It seems you are creating the package by hand and/or creating it in the wrong location (right location is catkin_ws/src). Please don’t do that. The correct way to create a package (say topics_quiz) is :

cd ~/catkin_ws/src
catkin_create_pkg topics_quiz rospy
# Where topics_quiz is the package name and rospy is a dependency. 
# You can add other dependencies after rospy as needed

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.