Exam correction fail & quiz solutions page not found

I have revised a couple of my answers in the exam some times. While my codes seem to work well manually, they return back as incorrect after the automated correction (f.e. small/medium/big_square task, get_laser_reading and main task). In all cases where the robot should move in a straight line forward, the robot slightly drifts so the squares are not necessarily squares and straight lines are not necessarily straight. However, while thinking that this should not affect the result, I tried to check the solution after a couple of tries, but this lead me to an address that does not exist (Error 404).
Now, I also cannot submit my answers, and looking for the solution remains to be linked to a non-existing page.
I would like to know if and what I am doing wrong in my code, and preferrably also go for the certificate.

Thank you in advance.

Hello @QuintdeKleijn,

I will check this issue with the Prerequisites Exam first thing tomorrow morning. I will let you know what I find out.



I think something is wrong with the grader.

My code works but there is ambiguity in the directions.

For example, there are many laser angles where the distance is “inf” so I return the first position.

get_laser_readings() works as well:

def get_laser_readings(self):

    r = self.robotcontrol.get_laser(???)  #### I put the correct value for righ

    l = self.robotcontrol.get_laser(???)

    return r,l

I don’t know why that is failing. I tested everything and it works.


I figured out the problem with get_laser_readings().

I still am having problems with medium and big square but it looks like I passed.

Would like the certificate but would also like to have my score updated to reflect the correct answer I gave.


in task2.sh, I start the scripts mentioned to do the robot perform a small, medium and big square, but it fails to perform the square with the given python scripts, executing them with “rosrun linux_exam medium_square.py” and the equivalent for the big square one.

Hi, I have the same problem, did you solve this?

Maybe I am having the same problem with the automated correction system for task2.sh.

When I use the command directly in the shell
rosrun linux_exam small_square.py
rosrun linux_exam medium_square.py
rosrun linux_exam big_square.py

The turtlebot turns so much in the corners that the shape of the trajectory does not look like a square.
It happens to any of the three codes

For the small square it’s less perceptive, but for the medium and big it’s more visible!

Hi @javier_robi @FreddyGarca @mauferrari,

Welcome to the Community!!!

Please note that the robot might not perform a perfect square. This is okay.

1 Like

Thank you for the information, my issue was related with the automated correction system, it said that the Medium and Big square did not perform correctly, also I get and incorrect answer in the task1 of Python, and it works perfectly

I have exactly the same issue;

manually I can run task2.sh with small/medium/big argument and it executes the correct square.
during the grading only small square is succesful.

I have the same issue. While the correction sequence is running, the turtlebot indeed follows the small_square, medium_square, and big_square sequences (neglecting that the turns are not nicely 90 degrees).

Hello everybody,

I will check this issue with the Prerequisites Exam first thing tomorrow morning. I will let you know what I find out.


I have the same issue.
The directions say “big_square” but the error says Medium square. Is this the issue?
My code works when I test it.


Hi all,

I have merged all issues with the exam here. My colleague @albertoezquerro is looking into the issues and will get back to us soon. Please be patient.

If you have submitted and gotten a grade, you can submit the exam again to get your grade upgraded, after the issues have been looked into.

Hello everybody,

After some tests, I have done some modifications to the autocorrection script, which should solve the medium and big square issues. Let me know if they get solved for you.


1 Like

good to hear changes are made so fast, however I did the exam yesterday, (medium_square and big_Square failed) and I wanted to see the solution, which resulted in error 404.

now I still get error 404, and I also can’t resubmit exam because i clicked “show solution”.

also task1.py is ambiguous:

  • what to return if there are multiple occurrence of ‘the highest value’ ?
  • does the position in list start at 0 or 1?
1 Like

@cornetjhu @javier_robi @abejkang @FreddyGarca @QuintdeKleijn

Sorry for all the trouble and thanks for your patience.

The 404 error when trying to view the solution has also been fixed. It was showing because we don’t have a solution for this Exam yet.

If you have tried to view the solution before, you can resubmit the exam now. We have “forgiven” you for viewing the solution since it did not exist anyways. :wink:

  • return the position of the first occurrence in the very unlikely event that that happens.
  • It’s a Python list so figure out the answer yourself :slight_smile: and fill in this blank.
    • Generally for most programming languages, the position of a list starts at _______

It looks like the tests for square.py are fixed but now I get:

“Error registering the result. Contact our support for more information.”

I passed the exam and would like to know how to link to the certificates.


Thank you, the changes in the correction algorithm worked for me, and it was graded >8 now, so pass.
However, the button to check the solutions is gone now, so I guess the score is now automatically sent after correction.
I’ll just wait for now.

Do you know how we get our certificates?