Exam fails to grade, disconnects after 3 first grades

The Linux for Robotics exam fails to grade after the first three sub tasks. It will hang and eventually disconnect, loading forever. Have tried multiple times, and left it for hours to see if anything changed, but nothing. Off note, it doesn’t count towards trials of the exam.

See below picture for an example.

Hi @s325927,

sorry for this inconvenience.

I’ve been checking the quiz logs, and the problem reported by ROS is:

./task2.sh takeoff
[rosrun] You have chosen a non-unique executable, please pick one of the following:
1) /home/user/catkin_ws/src/ros_basics_examples/linux_exam_cmd/src/takeoff_drone.py
2) /path/to/autocorrection_ws/src/linux_exam_cmd/src/takeoff_drone.py

So, the problem is that the autocorrection system has a script with the same name as yours, which is takeoff_drone.py.

Could you try to rename your takeoff_drone.py script and submit the quiz again?

Actually, this ROS complaint is actually strange to me because ROS should automatically choose the first one that appears in ROS_PACKAGE_PATH . It’s really common to have two packages with the same name as long as they are in different workspaces, but I’ll look into this later because this is a different problem.

Please let us know should you have any other problems.

Hi thanks for replying to my post, in that case we have a double problem. That package was added manually due to the file being missing from the exam, making it impossible to complete it.
See this post: Missing linux_exam_cmd in Linux for Robotics course

I will try to give it another name, update the bash files and let you know if it works.

Hi againt @ralves. Changing the filename in path


didn’t work unfortunatly. I also changed the names of the 2 other files being used in the bash script, land_drone.py and move_drone.py, but it didn’t have any effect. It is able to takeoff though (not graded, can see the model execute the action), but hangs again after that. I can see the file check_takeoff.txt appear as part of the grading process, but it never moves on from there.

I would guess the autocorrection system is not taking into account the missing files and the files I had to substitute them with.

Hi @s325927,

ok, then I need to have a deeper look into it.

I’ll be back to you once I have something.

I also am having the same problem and changed the name of those scripts but still cannot get passed the loading screen. Has a solution been found?

Hi @s325927 and @joubr13,

thank you very for pointing out these problems.

I’ve been investigating this issue and found the reason behind it.

To contextualize to newcomers, when @s325927 reported that the linux_exam_cmd pkg didn’t exist, I recommended downloading a repository that contains that package, and now, when you try to run the quiz, it fails because of a duplicated package.

That happens because the auto-correction system already defines this package, that is why a duplicated package is detected.

To solve this problem, you can just remove the linux_exam_cmd package you may have downloaded on ~/catkin_ws/src/linux_exam_cmd.

Even if when running rosrun linux_exam_cmd takeoff_drone.py you have:

user:~/catkin_ws$ rosrun linux_exam_cmd takeoff_drone.py
[rospack] Error: package 'linux_exam_cmd' not found

You can still submit the quiz anyway because as I mentioned, the auto-correction system already defines that package.

I know this is counter-intuitive, but we will soon install that linux_exam_cmd globally.

To summarize, please remove that linux_exam_cmd from your workspace and submit the quiz again, and let me know in case you identify any issue I may not have noticed.

i have the same issue with the exam, or sometimes it doenst grade at all
just get stuck in grading process without actually grading, and logging out after timeout.
i tried to remove the linux_exam_cmd by apt-get remove but i dont have premissions.
can you please help?

Hi @yoaves,

I don’t know how exactly you tried to remove that file, but could you try using sudo at the beginning?

You must have such privileges

Please, let me know if that worked for you


@marruda This error of only grading the first 3 items is still occurring (Jan 27, 2021). I am unable to remove the package as suggested. I tried
sudo apt-get --purge remove linux_exam_cmd

Hi @atbecker ,

the package must be in your ~/catkin_ws/src folder.

The command below should tell you the exact path:

find ~/catkin_ws -name linux_exam_cmd

Once you find the location, you can just remove it with something like:

rm -rfv ~/catkin_ws/src/linux_exam_cmd

Please let us know if even following these steps you still have problems.

Hello @atbecker

This issue should be solved now. You don’t need to remove anything, just correct the exam as usual.