Exam won't load notebook, terminal, workspace or simulation window

This is what I see when I open the Final Exam. It will not load any aspect or let me use any of the final exam. Does opening this still count as one of my tries?

Hi @malloyj,

Please try again after closing everything for about 20 minutes. If the problem persists please let us know.

No, this doesn’t count as a trial.

@bayodesegun ,
I have been experiencing this issue multiple times since around noon yesterday. I have tried restarting my system, as well as using different browsers and nothing works. If you have any other suggestions I am all ears! Thanks for your help.

Sorry to hear that. Can you have a look at this post for some hints? It could be that websocket connections are being blocked.

From what I can tell my firewall is allowing WebSocket Connections, and this issue has only affected me once I started the Final Exam. I have been able to complete all the other units and chapters in the ROS For Beginners course.

Hi @malloyj,

I would suggest you try another PC or Internet connection (both if possible), as this is usually the case when this problem appears. Let’s look at the following:

  • Are you seeing the same issue now in all courses now or just the exam?
  • Are you in a corporate network? If so, you need to confirm with you network admin whether the ports are open.
  • If you are using a personal connection, you might need to check with your ISP.

Please let us know if you are able to try the above.

For some reason I am now experiencing this issue with all courses. I have tried two different internet connections, and two different PC’s. Both internet connections and both PC’s have successfully run RIA before. Below is a screenshot from trying to run ROS Basics in 5 days.


Have you contacted the ISP or network admin? ISPs and network admin make changes from time to time, and this might cause some services to stop working.

This looks very much like an issue local to your connection or PC, because no one else is seeing this issue.

Just to confirm, you can ask you colleagues using a similar / different network to try? And please again can you check with your ISP so we can be sure?

Hi @malloyj,

could you load this address https://www.websocket.org/echo.html and click the Connect button just to make sure your computer is correctly allowing WebSocket Connections?

This will let us know where else to look if the problem is not in the Internet Service Provider.

We look forward to hearing from you.

1 Like

I’ve attached my report below. I believe I did it right, and I believe that my browser supports WebSocket. Thanks for your help!

Hi @malloyj,

So sorry for all the trouble. Thanks for your patience.

I think I’ve found the cause of the problem. Your VM was not properly initialized - I have corrected that and it should be fine now.

Please check it and let us know.

It is working properly, Thanks!

1 Like