Exercise 1.1/1.2 Error

I can’t seem to get the color blobs to be generated in Exercise 1.1, which I believe is why my 1.2 is not working. However, the example solutions are completely broken, so they aren’t any help. After multiple warnings while loading, the example solution for 1.1 ends up being stuck repeating the following error:

[ERROR] (2020-07-23 04:03:24.967) VWDictionary.cpp:672::addWordRef() Not found word 48087 (dict size=11338)

Hello @meclinto,

What errors are you getting? I’ve just tried the code and it worked OK for me:

About the database blobs you mention, I’m pretty sure they (the creators of the RTAB package) have removed them from the tool. I would need to investigate further on this in order to update this particular course. However, I’m pretty sure everything should work properly even without the blobs. I’ll investigate more and update on this topic as soon as possible.


Shortly after the example working, I ran the launch file again alongside the Rviz and the keyboard teleop module to begin mapping again, which resulted in the RTAB node dying. Now anytime I run the provided mapping launch file it ends up dying with the following errors:

[ WARN] (2020-07-25 02:00:44.557) Rtabmap.cpp:3939::getPaths() path.size()=0!? nearestId=0 ids=1, aborting…
[FATAL] (2020-07-25 02:00:44.557) Rtabmap.cpp:3279::process() Condition (_memory->getSignature(id) != 0) not met! [id=1]
terminate called after throwing an instance of ‘UException’
what(): [FATAL] (2020-07-25 02:00:44.557) Rtabmap.cpp:3279::process() Condition (_memory->getSignature(id) != 0)not met! [id=1]
[rtabmap/rtabmap-4] process has died [pid 6866, exit code -6, cmd /opt/ros/kinetic/lib/rtabmap_ros/rtabmap scan:=/kobuki/laser/scan rgb/image:=/camera/rgb/image_raw depth/image:=/camera/depth/image_raw rgb/camera_info:=/camera/rgb/camera_info grid_map:=/map __name:=rtabmap __log:=/home/user/.ros/log/480ab00a-ce1a-11ea-8695-0e2eded6de95/rtabmap-rtabmap-4.log].
log file: /home/user/.ros/log/480ab00a-ce1a-11ea-8695-0e2eded6de95/rtabmap-rtabmap-4*.log

The launch file I wrote also runs into the same problem.

When I ran the example code before, it would give out a lot of warnings, then be stuck repeating the error code I included in my original post, except the “Not found word” value would increase with every line. However, this time, with no modification to any of the code, it just spit out the same warnings as before but no errors. The warnings seem to indicate that many of the variables set in the example file are deprecated and should be updated, but I think the issue I was having has been fixed by the remote computer resetting. I had tried resetting the simulation and terminals many times, so I guess the only solution was to wait.

Send me your package to aezquerro@theconstructsim.com so that I can test it.