Exercise 2.15 Nothing is published on topic /map

Hi, I am stucked at the exercise 2.15 : the launch file worked correctly when the parameters were indicated directly within, but when I tried to load them from a YAML file, the gmapping/slam_gmapping node stopped publishing anything on the /map and /map_metadata topics. But at the same time, the console output seems to indicate that the parameters are loaded correctly.
I can’t see what could cause this strange behaviour, maybe you can help me ?


<node pkg="gmapping" type="slam_gmapping" name="slam_gmapping" output="screen">
    <rosparam file="$(find my_mapping_launcher)/params/gmapping_params.yaml" command="load" />


base_frame: base_footprint
odom_frame: odom
map_update_interval: 1
maxUrange: 2.0
maxRange: 8.0
sigma": 0.05
kernelSize: 1
lstep: 0.05
astep: 0.05
iterations: 5
lsigma: 0.075
ogain: 3.0
lskip: 0
minimumScore: 200
srr: 0.01
srt: 0.02
str: 0.01
stt: 0.02
linearUpdate: 0.5
angularUpdate: 0.436
temporalUpdate: -1.0
resampleThreshold: 0.5
particles: 80
xmin: -1.0
ymin: -1.0
xmax: 1.0
ymax: 1.0

Hello @marie.kalouguine,

It could be because the laser scan topic remap is missing. You should add the following line within the launch file (inside the node tag):

<remap from="scan" to="/kobuki/laser/scan"/>

Could you try this and see if it solves the issue?


1 Like

Yes, thank you, it work alright now ! I forgot that the name of the scan topic was different, but it’s actually totally logical.