Exercise 2.2 launch errors

I’m working on Exercise 2.2 and can’t get it to launch - I keep getting this error:



  • /rosdistro: kinetic
  • /rosversion: 1.12.14

move_robot_node (exercise_22/move_robot)


ERROR: cannot launch node of type [exercise_22/move_robot]: exercise_22
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/user/catkin_ws/src
ROS path [2]=/home/simulations/public_sim_ws/src
ROS path [3]=/opt/ros/kinetic/share
No processes to monitor
shutting down processing monitor…
… shutting down processing monitor complete

What am I doing wrong?


I tried rosrun and that works - does anyone have an idea why? Are my environmental variables screwed up some how?

A post was split to a new topic: Found the following but they are either not files or not executables

I did the same thing, I thought the error was from my code - so I copied and pasted their code and received the same error.

Figured it out, it was a operator error - I had a different spelling of the package name than in the launch file. Changed it and it now works! Double check your file naming.

1 Like