Exercise 3.2 Problem - unknown service

When I follow the solution to direct call the service /move_bb8_in_circle, it always shows the unknown service. I just copy the code to the python file and I checked there shouldn’t be other problems.


Hi @youngyangcs,

Please check that you have started the service server. When the service server is not running, this is the error that normally shows up.

First you need to create the service server according to the example given in the notebook, and then you start it using roslaunch.

Thanks for the reply. It works now.

1 Like

Hi I am also facing this problem and I checked that service server is running. Additionally I can call with it client launch file. What I am missing here


Welcome to the community!

Could please give more details about the specific error you are facing? Share a screenshot or something.

And here is one thing you can quickly check:

  • Have you run source devel/setup.bash on the terminal where you are tryng to call the new service?

Thank you :). I tried source devel/setup.bash before running script but it gives same problem. Here is screenshot robotignite|690x387

@borankecel99 You seem to be calling a non-existent service:

You are calling a service /custom_service_move_bb8_in_circle_server

  • Is that the name you were asked to give to the service, as per the instructions?
  • Is that the name you specified for the service in the code?
  • Shouldn’t the name be something like /move_bb8_in_circle?
  • After starting your service server, you can do rosservice list to see the available services.
1 Like

Thank you so much! I confused how to call service. I were trying to call node name instead of /move_bb8_in_circle. It solves my problem now.

1 Like