Exercise 6.3 - roslaunch issue

I am having issues on the last part of exercise 6.3.

I am trying to start the service server from a roslaunch file and then call it from a Python file

Here is the launch file:

start_bb8_move_custom_service_server.launch is in the same directory where this file is.

When I attempt to launch this file with
roslaunch my_examples_pkg call_bb8_move_custom_service_server.launch

I get the following traceback
while processing start_bb8_move_custom_service_server.launch: Invalid roslaunch XML syntax: [Errno 2] No such file or directory: u’start_bb8_move_custom_service_server.launch’ The traceback for the exception was written to the log file

Any ideas?

Hi @lclemen,

Try writing your include line like the one in the example below:

# turtlebot3_bringup is the package name
<include file="$(find turtlebot3_bringup)/launch/turtlebot3_remote.launch" />
1 Like

Thanks! That worked. I did have the original include work as well on a previous example. Any ideas why it worked once and not this time?

1 Like

No idea. Are you sure it was written exactly the same way? Did it actually work?

1 Like