[exercise3.1][Error]Unable to identify any set of controllers that can actuate the specified joints?

I am attempting exercise 3.1 in manipulation course and i stuck with this error , I tried editing the controllers.yaml file and controller_manager.yaml file as well but couldn’t figure it out.

my fetch moveit package:https://github.com/shivauchiha/ROS_Solutions_Robot_ignite_academy

I tried the same solution given in manipulation in 5 days book , i get the same error can someone help ? where I am making mistake? @staff

@bayodesegun sir can you help ? , I am in a rush . This course been delayed for 3 days because of this.

UPDATE - I had no choice but look into the solutions given in the notebooks. It works !
However there 2 issues.
1 -> the section for defining ROS controllers is entirely different , the solution asks user to use ros control given in MOVE IT SETUP itself . This handy because I don,t have to edit much files or define a controllers.yaml file. However the issue is there is no option for defining controllers for grippers within move it setup as the particular controller action message type(GripperCommand) is missing in drop down bar only.

2->The Instruction given in UNIT3 of course actually worked for the simulation in UNIT3 but no working in UNIT4 as shown in above pic , why is it so ?I thought both workspace had different Move it version , but i was wrong they are the same so why the issue ?

Hello @vasank1958,

Actually, as you’ve said, there are some parts of the course which are a little bit outdated, specially the ones involving MoveIt. That’s why I’ve been working on updating the notebooks for the last days.

In fact, I’m planning to do an update of the course tomorrow, which is going to include new chapters for the MoveIt and Grasping sections.

I’m sure this update will answer your questions in point 1 and 2. So tomorrow morning, as soon as I update the course, I’ll send you a message here and summarize a little bit what’s new on the course.