First Quiz Submit problem - package not found

Hi all, I have a problem with commit of the first quiz in the ROS2 Basics C++ course.

To the point, I created a topics_quiz package, application is buildable, is working (in my tests), but when I’ve tried to submit the quiz every single time I received the same answer:

It is nothing wrong with making a mistake, but I verified every single point from that list. As You can see in the screen below, the path should be correct. The package compiles and runs without any problems. It is also detectable by ROS.

As a matter of fact, I had run out of attempts to submit the quiz, but it would be great to know where I made a mistake. I hope that someone would be able to explain this :slight_smile:

Hi @mondiegus9 ,

I believe this is a glitch on the autograder / Gradebot.

The Construct team should be able to help you fix this.


You ran colcon build from the wrong place, ~/ros2_ws/src/. You must run this command from ~/ros2_ws/
You have essentially built a new colcon workspace at ~/ros2_ws/src/, but the gradebot is sourcing the workspace at ~/ros2_ws. The reason it works for you is because you are sourcing this new workspace, as you are in the ~/ros2_ws/src directory when you run source install/setup.bash

In summary, you are sourcing the workspace where your project is built: source ~/ros2_ws/src/install/setup.bash while gradebot is sourcing a different workspace: source ~/ros2_ws/install/setup.bash

Hmm… I get your point and see my mistake.
I’ve just compiled it from ~/ros2_ws/ and it was also successful. Correct me if I’m wrong. Does that mean that the Grabebot is not trying to compile it in some separate environment during submission, but it is 100% based on the current environment that I am working on?

Hi @mondiegus9 ,

The Gradebot does compile your package again (if I remember right).

Also, I have tried compiling my package outside /ros2_ws and within /ros2_ws/src - both that I also did by mistake - but my package has worked in both the cases just as it would when compiled under /ros2_ws. So this step should not be a big problem (as far as I know).

Even I noticed that path error in your initial picture, but since that does not make any problem, I ignored it. As long as you can execute your package after compiling, everything should be fine.


I have the same problem:

I had initially created my package in ~/ros2_ws/ instead of ~/ros2_ws/src/
So I moved ~/ros2_ws/ to ~/ros2_ws_old/, created a new ~/ros2_ws/ folder and new topics_quiz package, this time in ~/ros2_ws/src/.

Everything seems right now (see picture below), but I still get that error message.

Any suggestions?

Thank you,

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.