Gazebo does not show my robot model

HI @staff I am trying to spawn a robot and a car in Gazebo. I tried numerous times to spawn a car. But my gazebo “pseudo” spawn the car model. Is it to complex for it build 2 robots inside it? Because I don’t know what is going on…because I have copied the meshes file to gazebo’s models directory and there are not errors in my terminal…just warnings…and the model is there like a ghost in Gazebo.


I am very confused in locate where my problem is. If is my GAzebo limitation in read a urdf model generated by a xacro file, a plugin missing or whatever…the fact is that I tried numerous different car models which I found in github…and don’t work unfortunately.
And I am having often that warning after execute ctr-C to close Gazebo: "TErminate called after throwing an instace of boost::exception_detail::clone… which you can see in the end of the image below…
Some hint please?

Try activating the berbose tag when you launch the empty world launch. That normally gies you info about missing models.

Thanks @duckfrost I am sorry for my limitation…but how can I do this activation? :sweat_smile:

I have seen this:
roslaunch gazebo_ros empty_world.launch paused:=true use_sim_time:=false gui:=true throttled:=false recording:=false debug:=true verbose:=true

So in my case I use in my roslaunch:

roslaunch car_description prius.launch verbose:=true ?

This is enough? I will try

ok I used and have the same feedback from my terminal…because the model is loaded…it just does pseudo appear in Gazebo ( I can select the icons to move it…but it is like a ghost, can’t see it, but it is there). My model is loaded into the parameter server:

@duckfrost I could use a simple car…

However my idea was using a more real car such as the mkz or the prius, which I have seen in the classes and that you had the repositories…however to install and compile in my ws I had numerou issues to compile all their packages :“Autonomous vehicles” which required me the sicktoolbox pkd and derivates…well I dowloaded and had more issues…and issues to solve…
Then I used just the “main” directory for my purpose, the “mkz_description” and “prius_description”.
I think maybe these complex car use some features, controllers, plugins etc, which are dependent from their whole package, and maybe could I not just use the car_description package to spawn their models in Gazebo, or my Gazebo is missing frameworks to upload these models on it…I am not sure.
The fact is that I would like to use these car to finish my project on TF, where I would like to make the car follow the user…emulating that functionality of some new vehicles, when the car is parked and follow the user to make easy the user find its car in a big parking place…like shopping mall…
What hints could you give me in order to correctly and finally use these complex car models in my machine or should I upgrade to simulate in your best machines in ROS Develpment studio?
Is this environment prepared to simulate these complex urdf models? and how much should I pay to upgrade to use a very fast machine @staff ? Is there a promotion to student ( I am about 5 months with you hehe)
Thanks in advance

Well know I really trust that complex urdf/xacro models must have some kind of “secret” to compile/launch and spawn in Gazebo…
Because I launched using URDF in ROS Development studio and I could not see the model:

And later I launhced using XACRO in ROS Development studio and again the model is there but does
not appear:

I have copied for both models all the pkg to Gazebo:
cp -r /simulation_ws/src/dbw_mkz_description ~/.gazebo/
cp - /simulation_ws/src/dbw_mkz_gazebo ~/.gazebo/

Actually these directories were not inside simulation_ws but in an extensive path inside the construct core directories, which I used roscd command to find, and then I copied from this original path to gazebo directorie, in order to guarentee that all the meshes be copied.

I believe that maybe I am copying the directories, meshes to Gazebo in the wrong way? because I cannot understand why my model appear in Gazebo get world properties, but does not materialize in Gazebo…

My launch file is in ROS Development studio, it is called “TF_project”. To see the results you can launch the file: “roslaunch car_description dbw_mkz.launch” or the prius.launch.
I would be very grateful if someone could assist me on this.

The later I executed the original launch, which just launches the car…the dbw_mkz…
with roslaunch dbw_mkz_description mkz.launch.
For my surprise the Gazebo never loads this model kkkkk

Even in my notebook that is an ntel® Core™ i7-7700HQ CPU @ 2.80GHz × 8 processor with graphics Intel® HD Graphics 630 (Kaby Lake GT2) …
it does not open the model

So…I am convinced it is almost impossible to open a complex urdf/xacro model without having a NASA’s computer available hahahaha right?
I am really disappointed with ROS kakakak

Hey are you still having this problem? You might have to set the material tag to choose a colour inside your urdf file. Not sure why this is necessary but it works as long as you dont get any errors and the model shows up inside the tree structure.