Gazebo Simulation stuck loading


I am doing Mastering Turtlebot 3 course, 8th lesson simulation (Gazebo) doesn’t load.

1 Like

Hi @asaglam84,

could you try to reload the page?

If you change to other units, I suppose they load fine, right?

If even other units don’t load, could you tell us which web browser are you using?

Made CTRL + F5 didn’t work on unit 8. It is working on unit 3 though.

Could you take a screenshot and put here? So that we can see more precisely what is not loading, if it is the gzweb interface or the meshes.

I can easily describe; the section that is supposed to house Gazebo is stuck at the state Loading Simulation with a loader. On dev console I see I’m alive messages popping up if that helps.

Ok, then I’ll have to call @albertoezquerro here because it seems to need some further investigation.

In the mean time, could you try other units of the course, @asaglam84?

Sure, the issue here is we are subscribed to this course as a class of our university program. And we have a project with this unit whose deadline is on the corner.

Ps even the second part of the unit 8 is loading.

Ok, so I’ll also let @rtellez know so that we can give it higher priority.

1 Like

Hi @asaglam84 we have checked that everything is working in that course and unit (see image attached).

If you don’t see the simulation, it may be due to your browser. Remember that we only support Chrome and Firefox. Also, do not use Incognito mode because some times that gives some random errors.

Images attached: project part 1 and project part 2


I tried with different browsers to no avail. There are others in our group having problem too.

Also it could be related to last saved progress ? Are there any commands to reset the roscore or whatever is doing first initialization to gazebo here ?


Ok yes it could be to the packages that you have created in the catkin_ws. It could be that you have created a package with the same name than another, and then the launch of the sim cannot launch.
(roscore is provided by the simulation itself so you cannot restart it. It will start when the simulation is ok)
1st. send us a full screen capture with the error with as many details as possible (do not send only the window of the simulation, but the full screen).

In order to check if you have a problem in the packages of the catkin_ws do the following:

  1. Go to catkin_ws
  2. Type catkin_make
  3. if everything compiles without error, then that is not the problem.
  4. If there is an error compiling do another screen capture and post it here

Thank you, it got resolved

1 Like

Sorry to report it but it went back to loading stage again and stuck.

@rtellez I have no package name conflict. catkin_make built without any problems but problem still persists. There is another student who is in the same condition and he deleted every package and still no go.

1 Like

hello ,i am in the same situation. Not only me, my professor and my classmates has the same situation :unit8 simulation always loading. can you please to fix it ,it’s really an emergency.

API request failed (500): Traceback (most recent call last):
  File "/etc/jupyter/lib/python2.7/site-packages/tornado/", line 1592, in _execute
    result = yield result
  File "/etc/jupyter/lib/python2.7/site-packages/tornado/", line 1133, in run
    value = future.result()
  File "/etc/jupyter/lib/python2.7/site-packages/tornado/", line 261, in result
  File "/etc/jupyter/lib/python2.7/site-packages/tornado/", line 326, in wrapper
    yielded = next(result)
  File "/etc/jupyter/lib/python2.7/site-packages/notebook/services/contents/", line 247, in get
    checkpoints = yield gen.maybe_future(cm.list_checkpoints(path))
  File "/etc/jupyter/lib/python2.7/site-packages/notebook/services/contents/", line 524, in list_checkpoints
    return self.checkpoints.list_checkpoints(path)
  File "/etc/jupyter/lib/python2.7/site-packages/notebook/services/contents/", line 97, in list_checkpoints
    os_path = self.checkpoint_path(checkpoint_id, path)
  File "/etc/jupyter/lib/python2.7/site-packages/notebook/services/contents/", line 118, in checkpoint_path
  File "/etc/jupyter/lib/python2.7/site-packages/jupyter_core/utils/", line 13, in ensure_dir_exists
    os.makedirs(path, mode=mode)
  File "/etc/jupyter/lib/python2.7/", line 157, in makedirs
    mkdir(name, mode)
OSError: [Errno 30] Read-only file system: '/home/ubuntu/notebooks/t3_instruction_manual/.ipynb_checkpoints'

the response date is firday and saturday.

We have finally detected the issue. It works with some computers and others don’t. We are working right now to solve it


So its seems that if you clean your browsers Cache ( specially downloaded files and cookies ) it loads the simulation of Project part1.
It must have something to do with recent deployments in the web sim visuals. Because ll the cameras and ros systems are working. So it practical terms you can work without any problems.

Hope it helps, we will work on an automatic cache cleaning system asap.

at last we did the navigation task through rviz interface.
and thanks for your suggestions!

Thank you for the fix !
By cleaning browsers cache now it is loading correctly.

1 Like