Getting no response from map server Exercise 2.5

I have a map file saved in catking_ws/src

I tried doing :

rosrun map_server map_server my_map.yaml
and got the correct output earlier.

Then I wrote the launch file as per exercise 2.5 but I got this error:
user:~/catkin_ws/src$ roslaunch provide_map provide_map_launch.launch
… logging to /home/user/.ros/log/42af08de-28cb-11eb-8f90-0242c0a8e007/roslaunch-5_xterm-2424.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://5_xterm:37349/


 * /rosdistro: kinetic
 * /rosversion: 1.12.14

    map_server (map_server/map_server)


process[map_server-1]: started with pid [2433]
[map_server-1] process has died [pid 2433, exit code 255, cmd /opt/ros/kinetic/lib/map_server/map_server /home/user/catkin_ws/src/my_map.yaml __name:=map_server __log:=/home/user/.ros/log/42af08de-28cb-11eb-8f90-0242c0a8e007/map_server-1.log].
log file: /home/user/.ros/log/42af08de-28cb-11eb-8f90-0242c0a8e007/map_server-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete

Launch file:
<launch> <arg name="map_file" default="/home/user/catkin_ws/src/my_map.yaml" /> <node pkg="map_server" type="map_server" args="$(arg map_file)" name="map_server" output="screen" /> </launch>

After this I tried using rosrun map_server map_server my_map.yaml again just to see if every thing worked correctly, but nothing happened.

Hello @akshay.ulavan,

Is this error still happening? I’ve done some tests in this Unit and everything seems to be working properly. If it doesn’t please make sure that your map yaml file is correct and that it’s pointing to a valid pgm file (you can download the pgm file in order to visualize it).