Getting wrong results in ex5.6

I had my move_base node running and started rviz. Then I spawned an object in gazebo. Ideally, the global costmap shouldn’t show the newly spawned object but my global costmap map is showing the newly spawned object too.I have attaced screenshots of how the results in rviz for both the global and local costmaps. Kindly help if possible

My bad, I forgot to change the rolling window parameter to false from one of the exercises earlier. I hope this might help anyone in the future.

1 Like

Actually I thought that setting this parameter to false would solve the problem but it didn’t. The problem still persists. Here is my global_costmap parameters:

global_frame: map
static_map: true
rolling_window: false
track_unknown_space: true

  • {name: static, type: “costmap_2d::StaticLayer”}
  • {name: obstacles_laser, type: “costmap_2d::VoxelLayer”}
  • {name: inflation, type: “costmap_2d::InflationLayer”}

Hello @hrushikesh.kyathari,

The problem is that you are loading the VoxelLayer (obstacles_laser plugin) in your global costmap configuration, which takes the data from the laser. If you don’t want to have your global costmap updated with the laser’s data, you should remove this plugin.


1 Like