Grader failed while Testing on IDE run perfectly (Already checked file names)

I am working on ROS2 Basics in 5 days Humble, Unit 3 quiz.
I have tested it on IDE, and it worked well. However, when I submit it, my robot ran to parallel with the door then fail to turn 90 degree. and I got this message from the grader.

I did check by: ros2 topic echo /odom
and I see the response running, so why it still saying “not subscribed to /odom” ?

Hi @Hannah_Vu ,

Welcome to this Community!

One of the solution from people who had the same issue was to do the following:

  1. Compile the packages
  2. Verify if your package works as intended (by manually executing your package)
  3. If your package works correctly then go to step 4 and 5 else start over.
  4. Delete your build, install and log folders from ros2_ws
  5. Without building again, that is, without doing colcon build ..., send it to autograder / gradebot.

Hope this helps. Let me know if this does not work.


EDIT: Here is the link to the solution explained above: Services Quiz. Gradebot Fails to compile the package. How fix it? - #12 by oleg.a.kuvaev

Hi @girishkumar.kannan
Thank you very much for the response. I just tried all 5 steps you told me, but it’s still sending me the same message.
I am a bit worry now since I have used up 3 trials already. I only got 2 more.
Seriously, I tested it on IDE, it runs and gets out perfectly like this:

I don’t know what else to try :sob:

Hi @girishkumar.kannan

I got full graded now. I actually got a typo on the name of the node. This is so embarrassing. I am so sorry for that, and thank you for helping me out.


Hi @Hannah_Vu ,

Glad you got your problem fixed.

Since this issue is solved, you can mark your most recent post as the solution, so this issue can be closed.


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.