How to deploy bb8 simulation environment in local machine?

I am trying to simulate bb8 on my local machine .
using the link given in bitbucket:

I have already done the following

  1. Installed ROS according to wiki instruction
  2. created a folder catkin_ws/src and ran catkin_make inside it.
  3. Then inside catkin/src i cloned the repo .

After this what should i do ?

I am already half way through the course , but i dont feel confident unless i run the same environment in my local machine .

Thank You

Then you need to:

  • compile the packages (catkin_make)
  • source the compiled workspace (source devel/setup.bash)
  • launch the simulation (roslaunch bb_8_gazebo main.launch)

sir when i do catkin_make it says joycontrol.cmake is missing ?

sir when i do catkin_make it says joycontrol.cmake is missing ?

@bayodesegun sir i need help in compiling the bb8 package in local machine. when i do catkin_make i get joycontrol.cmake is missing what should i do?

Hi @vasank1958,

the joycontrol.cmake is missing because you need to install the ros-kinetic-joy package, assuming you are using ROS Kinetic.

In ROS Kinetic, these are the steps I used to create the catkin_ws:

mkdir -p ~/catkin_ws/src
cd ~/catkin_ws/
source /opt/ros/kinetic/setup.bash 

Now download the repository, on the branch kinetic-gazebo-7:

cd ~/catkin_ws/src
git clone --branch kinetic-gazebo7

When trying to compile, we have the dependency you mentioned, among others. I solved them with the commands below:

   sudo  apt-get update
   sudo apt-get install ros-kinetic-joy
   sudo apt-get install ros-kinetic-control-toolbox
   sudo apt-get install ros-kinetic-robot-controllers
   sudo apt-get install ros-kinetic-gazebo-ros
   sudo apt-get install ros-kinetic-gazebo-plugins 
   sudo apt-get install ros-kinetic-rgbd-launch

Now you should be able to compile:

 cd ~/catkin_ws

We recognize that there are too many manual steps to install dependencies. We may in the close future optimize our packages to easily install dependencies with rosdep install --from-paths ~/catkin_ws/src --ignore-src , but for the moment, the packages must be installed as aforementioned.

Please let us know in case you find any other problems.

1 Like

cmake is stuck at this error cannot find -lgazebo_ros_utils . I have done all sudo apt-get install

@ralves sir i still couldnt overcome the -lgazebo_ros_utils error can you help ?

Hi @vasank1958, did you manage to solve the -lgazebo_ros_utils issue?

no sir . Still couldnt get it working.

@ralves sir help? I still couldnt get it run successfully in my local machine.

Hi @vasank1958,

sorry for the late reply. Due to time constraints, I wasn’t able to follow up.

I’ll try to reproduce the issue again and come back to you by tomorrow.


Hi @vasank1958,

I just updated the bb8 repository, removing gazebo_ros_utils from the CMakeLists.txt found on the bb_8_package and now it should compile fine.

Could you try cloning the repository again and compiling it?

If for any reason you get an error like:

No rule to make target '/opt/ros/kinetic/lib/', needed by '/root/catkin_ws/devel/lib/'

this can be solved with:

sudo ln -s /opt/ros/kinetic/lib/ /opt/ros/kinetic/lib/

Please let us know in case you find any other issue when compiling.