How to have the simulations for Navigation course in my Personal Computer?

I am starting my learning with Navigation course. But I want to run the projects on my personal computer. At least turtle navigation. But I don’t know how to do that. Please help me

Hi @duygiangtemp,

each individual Unit of each course has its own requirements.

We use the Turtlebot, Husky and Summit XL robots in that course.

These simulations are available in the following links:

You would have to download these simulations to the catkin_ws/src folder on your own computer, and compile them. After cloning the repositories, you would have to change to the noetic branch (using git)

These are just the simulations, but you will probably need some other packages.

You would have to install those packages. Which packages, you may ask? Well, the errors that appear when trying to load the simulations using roslaunch should give you a hint.

As I said, each Unit has its own individual dependencies, so, I cannot list here all dependencies needed for each Unit.

The simulations aforementioned are the starting point. Just install them, and try to launch one of the launch files.

I ran the launch files as in the course
roslaunch turtlebot_navigation_gazebo gmapping_demo.launch
roslaunch turtlebot_teleop keyboard_teleop.launch
roslaunch turtlebot_rviz_launchers view_mapping.launch
But my computer doesn’t show any simulation except Rviz. Is this a bug, and how can I display the turtlebot like on the web

If the simulation does not show up, you have to watch for the logs on the terminal where you launched the simulation, and based on the errors, try to find a solution on Google.

Please watch the errors.

Check also the ROS Parameters that appear when launching the simulation. Maybe there is a parameter saying not to launch gzclient (the visual simulation). If it is in headless mode, for example, the computation is made but nothing is shown. Also, make sure you have Gazebo installed and sourced.

Some errors may also be found on ~/.ros and ~/.gazebo folders.

I have reviewed the terminal log and don’t know how to solve this problem.
When I run these 2 commands:

  1. roslaunch turtlebot_navigation_gazebo gmapping_demo.launch
  2. rosrun rviz rviz
    Then my personal computer terminal output is as shown below
    Can see a little difference between my terminal and web terminal
roslaunch turtlebot_navigation_gazebo gmapping_demo.launch
... logging to /home/giang/.ros/log/62e61b32-06e1-11ee-8569-e31336e33804/roslaunch-coi-13755.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://coi:34903/


 * /rosdistro: noetic
 * /rosversion: 1.16.0
 * /slam_gmapping/angularUpdate: 0.436
 * /slam_gmapping/astep: 0.05
 * /slam_gmapping/base_frame: base_footprint
 * /slam_gmapping/delta: 0.05
 * /slam_gmapping/iterations: 5
 * /slam_gmapping/kernelSize: 1
 * /slam_gmapping/lasamplerange: 0.005
 * /slam_gmapping/lasamplestep: 0.005
 * /slam_gmapping/linearUpdate: 0.5
 * /slam_gmapping/llsamplerange: 0.01
 * /slam_gmapping/llsamplestep: 0.01
 * /slam_gmapping/lsigma: 0.075
 * /slam_gmapping/lskip: 0
 * /slam_gmapping/lstep: 0.05
 * /slam_gmapping/map_update_interval: 5.0
 * /slam_gmapping/maxRange: 8.0
 * /slam_gmapping/maxUrange: 6.0
 * /slam_gmapping/minimumScore: 200
 * /slam_gmapping/odom_frame: odom
 * /slam_gmapping/ogain: 3.0
 * /slam_gmapping/particles: 80
 * /slam_gmapping/resampleThreshold: 0.5
 * /slam_gmapping/sigma: 0.05
 * /slam_gmapping/srr: 0.01
 * /slam_gmapping/srt: 0.02
 * /slam_gmapping/str: 0.01
 * /slam_gmapping/stt: 0.02
 * /slam_gmapping/temporalUpdate: -1.0
 * /slam_gmapping/xmax: 1.0
 * /slam_gmapping/xmin: -1.0
 * /slam_gmapping/ymax: 1.0
 * /slam_gmapping/ymin: -1.0

    slam_gmapping (gmapping/slam_gmapping)

auto-starting new master
process[master]: started with pid [13766]

setting /run_id to 62e61b32-06e1-11ee-8569-e31336e33804
process[rosout-1]: started with pid [13779]
started core service [/rosout]
process[slam_gmapping-2]: started with pid [13786]

Please help me

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.