How to open RVIZ2

Hello, I’m currently studying the course : ROS2 in 5 days (python), I am at the 6th unit, in the 6th unit I need to work with RVIZ2 , however I am having trouble in understanding how to connect to it.
all it says is type the line: rviz2 in the shell 1
after that i get these 3 messages and nothing else happens:
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-user’
[INFO] [1638715918.785889744] [rviz2]: Stereo is NOT SUPPORTED
[INFO] [1638715918.786026063] [rviz2]: OpenGl version: 3.1 (GLSL 1.4)
[INFO] [1638715918.838462858] [rviz2]: Stereo is NOT SUPPORTED

Hello @eziotheking ,

It is important to remember there is a button to open any graphical tools you may run during the course. Have you tried to open it?

Could you share a screenshot of your workspace?


thank you. yes i just noticed it :smiley: , another question, I am currently doing the path planning course and in the 2nd page i imported the package from the github link that we were giving using the CMD’ when i try to run unti2_exercise.launch (same with unit 3 4 5…) I get the following error in the console:

RLException: [unit3_astar_exercise.launch] is neither a launch file in package [unit3] nor is [unit3] a launch file name
The traceback for the exception was written to the log file

what do i need to do ?

Hi @eziotheking ,

There are some options:

  • There is a typo on your command. E.g: unit vs utni
  • Your $ROS_PACKAGE_PATH is not configured properly. You can reset it by sourcing your workspace again

Could you paste a screenshot of the commands you have executed?

Hello , my issue was solved :slight_smile: , I didnt notice that i had the button to open the RVIZ program so false alarm

1 Like