How to reset the simulation

I have just registered as a user and am following the navigation course. After completing Basic Concepts I moved to Mapping. I ctrl-c’ed all the terminal, I executed the command to remove the blue obstacle, but the simulation seems to be still running, without allowing me to start a simulation.
I would appreciate help on resetting the simulation environment.

Hi Sarah,

Welcome to the community!

In order to reset a simulation, all you have to do (usually) is to move to a different unit containing another simulation and then come back to the current unit.

Can you try this and let’s know how it goes?

Hi @sarah.e.keren, hope you are doing well. So within the course in the simulation window there is a reset button in the top right corner of the window. Have you tried using that?

1 Like

@shahramnajam.neduet Thanks for that suggestion. If the a program controlling the robot is running, however, the robot will still keep moving.

Changing to another unit also stops any running program, so this is the favorite approach :bowing_man:

I have tried the reset button in the simulation window and also moving between modules. That didn’t work. I also tried to remove the blue object that was used in the intro to the navigation tutorial, but the command failed. Trying it now, after a couple of days - it seems to be working. I hope this issues will not re-occur.

Hi @sarah.e.keren,

Glad to know you got it working now. I apologize for all the trouble. The thing is that Gazebo simulations can sometimes go crazy and refuse to respond as expected, sometimes for no apparent cause. In such cases, a reset is necessary.

Should it reoccur, please follow the suggestions here and let us know if they don’t work. There’s a “last-resort hard reset” we can do from here.