I have an error in ros2

when i follow this command
ros2 run ros1_bridge dynamic_bridge

i get an error message this
[ERROR] [1581251903.257094373]: [registerPublisher] Failed to contact master at [localhost:11311]. Retrying…

1 Like

Hi @hknam3433,

You might get that error when the connection is not yet ready. If you wait a few more seconds (without stopping the program), everything should be fine.

Could you please try that?

I get the same error, I tried waiting but that did not work either.
[ERROR] [1583260589.221525248]: [registerPublisher] Failed to contact master at [localhost:11311]. Retrying…


This error is generated by the fact that you create an environnement variable like this : export ROS_MASTER_URI=http://localhost:11311

In fact, inside the environnement variables of the linux simulation, ROS_MASTER_URI need to be :
export ROS_MASTER_URI=http://master:11311

After that you can execute : ros2 run ros1_bridge dynamic_bridge, it will works.

1 Like

Thanks @arjunvenugopal07. Are you able to get it working @IlknurUmay @hknam3433?

Welcome to the Community @arjunvenugopal07 @IlknurUmay!