IDE is not loading

IDE is not opening. It starts loading and then it is blank. This is happening for the 1st time.

Hi @jahnavi.konduru,

Thank you for letting us know and welcome to the Community!

I’m sorry that you have experienced this. I see that you were trying to load the ROS Basics in 5 days (Python) course and I have just tried and could open the IDE successfully. Could you please reload the page and give us further details in case it happens again?

  • Is it only the IDE that is not loaded? Can you share a screenshot?
  • Are you experiencing slow or unstable internet connectivity? The IDE might take longer to load on connection speeds less than 2mbps.
  • Are WebSocket connections blocked - ws:// and wss://. Please ask your network admin in case you are in a corporate environment.

Thanks again. Please let us know.

Hi @jahnavi.konduru,

This is pasting in your reply via email:


Its just not ROS Basics in 5days. For any course my IDE is not loading. I am currently doing ROS BAsics in 5days and ROS Navigation course. I try to open any course the IDE is blank. Please find the screenshot attached.

I need this to be resolved as immeditely as possible as I am doing this course because of my work and this doesnt work. I am guessing the issue is with my login. It was working till Wednesday and all of a sudden stopped working from yesterday.

I have replied earlier through the mail as I got a copy in that. Anyways as per the above reply I have sent, that is the screenshot and if you see there is a blank screen instead of the IDE with catkin_ws. This is happening with all the courses and not just one.


Thank you for giving more details about problem, it’s very useful. Again, I apologize for the problem.

It’s looking like this has something to do with your Internet access. I see that your IP address is changing, sometimes it takes address close to Europe and sometimes an address close to the US:

  • Are you using a VPN?
  • Are you behind a firewall or proxy?
  • Again, are ws:// or wss:// being blocked?

There are a few things I’ve been able to cross out:

  • It doesn’t seem to be the browser and I see you have used both versions of the browser.
  • It’s doesn’t seem to be something with any course because it’s happening with all courses, and it’s not happening here.

Please do the following so we could see more clearly what the problem is:

  • Try using a completely different Internet connection, if possible.
  • Should the screen go blank again, please show us the most recent logs on your browser’s console (in a screenshot or you can copy it):
  • If you are online now, please stay online so I can check your instance in real-time.


Thanks for the quick reply. To answer your questions regarding the address and VPN, I live in Germany, Europe and I am accessing it from Germany only.

  • Are you using a VPN? - No
  • Are you behind a firewall or proxy? - I am trying to access this in my company system but it was working fine till 2days back in the same network.
  • Again, are ws:// or wss:// being blocked? - I dont think this is blocked as I have verified it with some online tool and it says its working fine.

Please find the screenshot for the logs.

And I am online now. Doing the ROS Navigation course


Thanks for your quick reply.

I still think it has something to do with accessing via your company’s internet access - can you speak with your company’s network admin about it? From what you shared, there’s no message from the IDE at all, and it’s very strange. :thinking:

I suppose you are not able to try another Internet connection (and better still a different PC not associated with your company)right away, but please try that as soon as you can so we can isolate the problem.

In the meantime, could you please do the following while you have the browser console open and send a screenshot?:

  • Right click in the IDE area and select “Reload frame” or similar to reload the IDE only.
    • In Firefox it’s This Frame > Reload Frame
    • In Chrome it should be in the main menu.
  • Observe the messages in the console and send us a screenshot again.

I’m also checking your vm from here and might be able to catch something.


I will check the access once I reach home in a different IP. For now I have followed the same by doing reload frame. Look into the attached screenshot.

Thanks so much, let me research about that error. I can see clearly now that the browser is not even loading the IDE because that error is stopping it. There is no request for the IDE, so there are no logs on the server.

Somehow, the code that is supposed to load your browser is running into an error. Perhaps your browser cache is interfering with the new IDE code. Let’s try the following:

  • Open the course in a guest window in chrome.
  • Also open in an incognito window in Chrome.


I tried in both Guest and in Incognito mode and both are not working.

I tried in a different IP with the help of my friend and it worked there. But I need to personally check once again at home.

But the issue is in this office IP which I am doing my course was working till wednesday and suddenly stopped working. This is a wonder.


1 Like

Hello @jahnavi.konduru,

Thanks so much for letting us know. In addition to checking with the Internet connection at home:

  • Use another PC if possible.
  • Try to get help from your IT department.

Why? It might not be your office IP (only) but the PC you’re using, because I see that the browser is having some problems reading the IDE code.

In any case, please let us know how it goes so that we can all learn.

Thanks again!


I tried using different PC before reporting here. That as well did not work. I was just wondering how could it happen overnight as it was working fine before. Anyways I will check the connection at home and get back to you here so that you can be aware of the situation.

Thank you very much for your help.


I also have a similar problem. IDE window stucks showing the animated loading circle. But Interestingly it happens “only” ~80 % of the time I try to start/resume a course, same computer, unchanged network settings.
In another thread, it was advised to start another course then switch back to the original. It worked at the beginning, but with each time using this trick, the chance of working decreased :frowning:

Hi @hyun-suk.jung,

Thanks for letting us know. Welcome to the Community!

I apologise for the inconveniences this has caused you.

Should this happen again, please try the following and let us know if it works.

  • Right click in the IDE area and select “Reload frame” or similar to reload the IDE only:
    • In Firefox it’s This Frame > Reload Frame
    • In Chrome it should be in the main menu.
1 Like

IDE Window still stucks regularly when loading the whole page but using

then solves the problem! Thanks!

1 Like