IDE loading error

I was trying to fix package import error and tried to follow some of the solutions on the discussion forum. I did something and the catkin_make was not working properly - it showed “Invoking “cmake” failed”. So, . I downloaded the “catkin_ws/src” directory backup on my PC and tried the solutions from the following threads to reset catkin_ws - Invoking "cmake" failed and How to reset catkin_ws (ROS catkin workspace) and start afresh.

But now my IDE keeps loading as shown:

Thanks in advance.

Hi @amkarkare96 ,

Welcome to the Community!

I have faced the same issue. Just click on the “reload” button that is at the bottom right corner of the IDE, exactly above webshell #3.

In case this does not work, clear your history and cookies in your browser and load this course page again.


1 Like

Thank you very much. The reload button worked.

Do you have an idea on how do I restore the package directories. I had downloaded the src folder as compressed file (.tar). I am not able to upload the folders directly. Will I have to create all packages and sub-folders again and reupload the associated files to each of the folders?

Just had to extract the file using the following command in shell:

tar -xvf .tar

Hi @amkarkare96 ,

Glad to know your problem is now resolved.

To upload a folder back into the IDE from your computer do the following:

  1. Make the folder into a compressed file zip / tar - anything would work.
  2. Drag from your computer folder window and drop into IDE left panel - under whichever folder you want.
  3. Extract the compressed file there and delete the compressed file after extraction.

VERY IMPORTANT: If you have replaced the contents of src folder, make sure that after you uncompress, you run catkin_make if you are using ROS(1) or colcon build if you are using ROS2. Also, don’t forget to rename your folder as src in case your folder name is different.


This topic was automatically closed after 21 hours. New replies are no longer allowed.