IDE not loading

Hi, none of my course’s IDE is appearing. All of them seems to be stuck on the loading window. I’ve made sure I’m not using incognito, I’ve disabled ad-blocks and allowed cookies as per instructed in similar cases but the IDE still isn’t loading for me. Is there anything else I’m missing? here’s the appearance of my window


Did you try to refresh the page? Sometimes, depending on the internet connection the IDE might get stuck, and refreshing you solve the issue.

I did! I just tried again today :frowning: it’s still not working, I’ve tried with another device, it doesn’t work either… Perhaps I will try using mobile data to connect but if that doesn’t work either I’m out of clues.

update : I tried using different internet connections it still isn’t working. Might the problem be elsewhere?


Sorry to hear that. I tested again and it gte stuck in the ide loading but when I pressed the relaod button of the IDE it loaded:

Screenshot from 2021-05-03 09-38-01

Could you press F12 in the Crome browser and select the console and make a screen capture just in case we can see some error message there? Becuase it might be something in your system. Also could you try on another Computer? Becuase its really strange.

By F12, I’m guessing you mean the web inspector? I’ve tried opening it, it shows as follows.
I’ve tried opening it, it shows as follows.

I’ve tried using chrome in another device the IDE seemed to work. I’m currently using safari, I will try to use chrome on this device and update you on it. Thank you!

update : it works on chrome! I guess I’ll use that from now… still not sure what was wrong with the other browser though. Thank you so much for the help!

1 Like

We officially support only Chrome and Firefox at this time. Also, we have seen that the IDE might not work in “incognito” or private mode.

Good to know.

Yeah, Chrome and firefox are the ones that are supported. Safari has its own little quirks that make it unstable sometimes.