ImportError: No module named *.msg/.srv/.action

As you can see on topic message, for service and action I have that error and I cant find the solution.

I followed the same steps with ;
Solution Exercise 2.2
Solution Exercise 2.3

Hi @bulutenesemre,

Please have a look at the following points in the order shown and let’s know if that helped:

  1. Have you made the necessary and correct modifications to your CMakeLists.txt file after creating the .srv/.srv/.action file?
  2. Have you run catkin_make ?
  3. Have you run source devel/setup.bash on every shell where you are using the custom message?

I tried all way which said before.

Even I watch how to solve that error published by the construct on youtube.
With ; source ~/catkin_ws/devel/setup.bash
I run ; roslaunch exercise41 publish_age.launch
And result ;

process[publish_age_node-1]: started with pid [19408]
[publish_age_node-1] process has finished cleanly
log file: /home/user/.ros/log/31a3e78c-adf5-11e9-826e-0242ac120007/publish_age_node-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor…
… shutting down processing monitor complete

@bulutenesemre something is definitely wrong. To start with, please paste the complete shell output here, from the point of running roslaunch exercise41 publish_age.launch to the point where the program exited.

Here output ;

@bulutenesemre, that error means that your custom message has not been properly setup. There must be some error in the whole process from creation to compiling to sourcing the workspace.

To proceed, you could:

  • review the notes again and check that you have done everything as specified, and according to the hints in that post. This will be faster. OR…
  • send the affected package to me in a private message, and let me have a look. (You can download the package by right-clicking on the package folder name on the IDE and clicking “Download”). It might take some time before I can review this.

I send you private message please as soon as possible lets solve this problem cause it makes me slower about that course @bayodesugun

1 Like

@bulutenesemre, I’ve checked your code, just a minor bug :sweat_smile:. In your, change

while not rospy.is_shutdown:


while not rospy.is_shutdown():

It was just the missing (). The code just ran through and did not stop at the loop because rospy.is_shutdown just returns the function (which is truthy) instead of calling it (which can return True or False).


Hello @bulutenesemre , have you solve this problem yet?
The latest reply from @bayodesegun was saying that missing “()”, but I can see in the screenshot of you first post, the “()” was not missed.
What is the true cause of this problem, have you found it? I have the same problem here.
Thanks for Sharing!

Hi @253874655,

Welcome to the community!

In the code that @bulutenesemre sent to me privately, the () was missing. I suppose it was not missing initially but as he was trying to fix other problems the () somehow disappeared :slight_smile:

Please post the exact error you are having, preferably in a new post.