Iri_wam_aff_demo package does not exist

I am currently in unit 5 but I cant do it because for some reason I dont have the iri_wam_aff_demo package. I have looked everywhere. even in /opt/ros/kinetic/share there is 500 + packages but none of iri_wam_aff_demo

Hi @Dukes11,
You don’t have to search for the package as such, when you start unit 5 you should be able to see a robotic arm in the gazebo simulation window.
run the command: roslaunch iri_wam_aff_demo start_demo.launch to start the demo.

Further you don’t need to manually search for packages in ROS, for example if you want to go to the iri_wam_aff_demo package try roscd iri_wam_aff_demo
you current directory should change to /home/simulations/public_sim_ws/src/all/iri_wam/iri_wam_aff_demo

Thanks for the reply!
when I type roslaunch I usually press tab to autofill. In this case nothing happens, and when i double tap it doesnt print out anything. When i write the whole command it says that it cant find the package and ive tried to source devel/setup.bash, rospack profile, everything still nothing

that’s strange, maybe someone from the moderators team might be of help.

How do I contact the moderators?

They are active in the form, they usually reply to all the unanswered questions more or less in a day or so (time zone differences).

Hi @Dukes11,

Welcome to the Community!

I’m sorry you had this issue. It’s strange as @textzip mentioned. Could you please check again and let us know if the problem persists (it might have been a temporary error with your setup)? I can find and run the package here.

Thank you!

I still got the same problem. I am typing “roslaunch iri” and then I press tab to autofill but it won’t.
I copy the whole command from the tutorial and paste it in and when I press enter I get this error:

[start_demo.launch] is neither a launch file in package [iri_wam_aff_demo] nor is [iri_wam_aff_demo] a launch file name
The traceback for the exception was written to the log file

I appriciate the help!

Hi again!
I don’t know if I have to post this seperatly but I got the same problem with unit 8. It seems that ardrone_as package doesn’t exist. I can only find ardrone_autonomy package.

I appriciate the help!

Checking from here, the package exists. This is what I got:

user:~$ roscd ardrone_as/action; cat Ardrone.action
#goal for the drone
int32 nseconds  # the number of seconds the drone will be taking pictures

sensor_msgs/CompressedImage[] allPictures # an array containing all the pictures taken along the nseconds

sensor_msgs/CompressedImage lastImage  # the last image taken

Could you please share what you get when you run that command?

Hi, can you tell us which course of these two are you using?

  1. ROS Basics in 5 Days
  2. ROS Basics in 5 Days Noetic
user:~$ roscd ardrone_as/action; cat Ardrone.action
roscd: No such package/stack 'ardrone_as/action'
cat: Ardrone.action: No such file or directory

This is what i get :confused:

Hi, I’m using the ROS Basics in 5 Days

Hi, the fact that your system can’t find this directory is very strange. On this side everything works as expected. I recommend closing the course completely and trying again. These packages come preinstalled. Can you tell me what you get by typing

roscd parrot_ardrone

Hi, yea it seems very strange. But I started the course again from the beginning in noetic so if i run in the same problems i will let you know. I don’t mind doing it all over again, good practice :slight_smile:
thanks for the help

1 Like

Thank you, let me know if you run into the same issue

A post was split to a new topic: Iri_wam_aff_demo package does not exist (ROS Basics C++)