Iri_wam arm - won't reset and drooping

Hi, I am trying to roslaunch iri_wam_aff_demo start_demo.launch for learning how to use the rqt_plot function. When I try to launch the launch file, there robot will not respond.

When I hit the reset button on the simulation, the robot does not reset. Also have tried

rosservice call /gazebo/reset_simulation "{}". This will reset the robot arm until it is vertical, but then it will slowly begin to fall until the arm is fully collapsed.

Hi @nrjbs87,

I apologize for this problem you faced. In order to help you faster, could you please mention the exercise or example you were following?

Hi @bayodesegun,

I am doing exersize 5.1 in the Chapter 5.

Hi @nrjbs87, please try the following:

  • Ensure you don’t have the roslaunch iri_wam_aff_demo start_demo.launch program running in another terminal.
  • Reset the simulation by going to the previous chapter (which has another simulation) and then coming back to this chapter.

I experience the same problem on that exercise. Any other solution?

If it is any consolation, solution from @bayodesegun worked for me.

1 Like

Yeah it helped me too, would be cool to have reset gazebo button. :slight_smile:

1 Like