Is it possible? package 'move_bb8_pkg' not found

I am trying to follow the last exercise in the course LINUX FOR ROBOTICS and exactly (3. Advanced utilities)
Why does the robot execute the command and find the package?

By the way I named my file to instead of

Thanks for the help!


All things are possible :slight_smile:. rospack may not have found your package, but if it’s correct and especially if it’s Pyton code, it might still run.

Try to make the rospack error disappear::

  • Ensure you have run catkin_make and then source devel/setup.bash.
  • Also run rospack profile.

Btw, welcome to the Community!

1 Like

Dear Bayodesegun,
Thank you for you answer!
Kindly see the photo I sent. :slight_smile:

Best regards

Have you run the commands I suggested?

cd ~/catkin_ws
source devel/setup.bash
rospack profile

Hello, i’ve had the same error, and I’ve run the commands you suggested but the file still runs after changing the path in the environment variable.

Hi @diego98cs,

Welcome to our community.

Is this error still happening to you?

Could you copy and paste here the error message you are getting?

Please make sure your package have the right name.

In the last case, could you please also paste here the output of the command below?

tree ~/catkin_ws/src

As you can see, I’ve changed the path in the environment variable, but when I run the file it works even though it’s not supposed to work.

And finally the output you requested me.

What I can see here is that ~/catkin_ws/src is not included in ROS_PACKAGE_PATH.

Even if you run the commands below, the error still happens?

cd ~/catkin_ws
source devel/setup.bash
rospack profile
env | grep ROS

After the commands here exemplified, the env | grep ROS should show ROS_PACKAGE_PATH with catkin_ws/src on it.

Yes, the path is not included in ROS_PACKAGE_PATH because in the last example of unit 3 we are supposed to change it so when we try to run the program the package is not found, but after I do what it says in the course, the program still runs even though it’s supposed to give an error and not run.

Hey were you able to solve this?

Hi @aksh.shendge ,

please try sourcing your workspace first with:

source ~/catkin_ws/devel/setup.bash

If it does not work, then compile your workspace:

cd ~/catkin_ws
source devel/setup.bash
rospack profile

After that, rosrun should be able to find your package.