Is it possible to delete/revert the notebook from a course? (Deleted install and build directories and now workspace won't build)

While working on the ROS2 Basics in 5 Days Course (C++), for section 4.8, I created executor_example_5.cpp, modified the CMakeLists.txt as instructed, then went to build the project. The build took 6 minutes to get to 50%, and then didn’t seem to progress.

I decided to delete the /build and /install directories in ros2_ws to try a clean install. Now, nothing seems to build.

I have downloaded/backed up all my packages already. Is it posible to revert this workspace to the default state, or revert it to how it was a day or two ago, so I can try again?


1 Like

deleting install and build directories should not impact your colcon build command, even git is usually used only for the src folder.
try deleting the log folder as well and try building again.

Thanks @skvallab I will try that and update. Right now it has been running for 15 mins and is 61% built.

It is still not building. I can build all packages separately fine, but when I run a colcon build on the workspace, it never finishes building (I’ve waited over 1 hour). Any advice?

I downloaded all my packages, deleted them from the workspace, placed them back, and now the build works.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.