Issue with writing image from drone in Exercise 2.2

When trying to complete exercise 2.2 I seem to be having an issue with an image being saved from the drone. I tried my own code previously and I couldn’t get it to work so I copied the solution and I still be seeming to have issues. Is there a button I’m supposed to press to save the image, or when I run my launch file should it work? The script itself seems to work as the NASA image shows up in the graphical interface, but I don’t see a “drone_image.jpg” showing up in my directory and when I search for it it also does not show up.

This causes an issue in exercise 2.3 as well since there is no drone image to load at it gives me an error because of this. Any ideas what could be wrong?

The issue seemed to be with where the drone_image.jpg was saved. For me it was saved under the path example_path = ‘/home/user/.ros/drone_image.jpg’ so changing it this way fixed the issue. I am not sure how to set the default save path for the image, however, so if anyone could help me with that it would be much appreciated!


Hello @battistini.jarrett,

I’m glad you could solve the issue by yourself. You set the path where to save the image in that variable, so in case you want to change the path you would need to modify that variable again.