Launch simulation.. stuck

Hello, no matter witch course I try to start. The loading stops at Launch simulation… It used to work just fine. Please help (The terminals also dont load)

Please what am I supposed to do ???

OK, after few hours it suddenly started working again, but really odd.

1 Like

Hi @t.hri,
We are sorry for this error; we are looking into why it happening and how to prevent it from happening.

Thanks for reporting it and thanks for letting us know it’s working again.

I am having the same problem, Thursday August 22 2019, 10 :15 AM (GMT +3). I tried different browsers, different connections, but no go.

Hi @weaverj,

we just put on production a fix for this issue.

If it happens again, the system should recover itself automatically.

If other users notice it in the next few hours, it may be because they are still using the old version of the remote computer, but in two hours or so, people should no longer have this issue.

In any case, we will be happy to be notified in case anyone still experiences it after 10:40 GMT.

1 Like

Thank You ! It is working now.


I have the same issue, Launch simulation is stuck


Can you tell us if you are still having this issue? I just loaded a course now and it worked fine.

bayodesegun, It works fines fine now.


1 Like

launch is stuck again for several hours.

it works now, seems its On and OFF

Hi @cshreyastech, thanks for letting us know.

Since it is a problem that appears “randomly”, we are going to investigate why that happens to make sure it doesn’t happen again.

I’ll let you know when we identify the cause and have a definitive solution.

@ralves, thanks for looking on to this.