Move_bb8_in_square_custom not found


I have tried to submit the quiz but all tries went in vane due to an error that /move_bb8_in_square_custom is not found. Please see my code, the service name is same as this one. And I have done the same thing ROS basics in 5 days for C++ but it is not working for python. I can even see the service name by rosservice list. Is there a problem with auto-checking? Because one time it crossed this stage but due to combined launch file i had to re-submit it. And then it never went pass that point. Can you please have a look at it and if correct then please increase my try?

Here is the rosservice list result:

Have you checked that you killed all your terminals before running the grader? Maybe the service server is running in the background and that could affect the grade.

And again, please go through the instructions carefully one more time just to make sure you are not missing anything.

Right… Although service server was not running in the background but still let me try again…

Can you please check your mail and guide please? Because I have attached a video file related to difficulty i am facing while submitting quiz.

Launch file name was correct but this time I submitted quiz with service server running in the background and it did find the service. Got full marks. :slight_smile: It doesn’t detects service without running server at the background.

This is not the case. You don’t need to have anything running to pass the quiz.

The grader tries to start your service server using the launch file you created. It’s exactly the same grader for the Python and C++ courses.

Right… Thank you… But this worked out for me… :slight_smile:

This topic was automatically closed after 43 hours. New replies are no longer allowed.