Moveit error: Failed to contact master at [3_xterm:11311]. Retrying

Hi TheConstruct,

I’m trying to build a Moveit package for my robot, in ROSDS (in My Rosjects I’m building).

and I got the error below,

tried rebooting here and there many times, tried to build in the course or even loading an existing working moveit, get the same error, I just tried again , it works in the course but does not work in ROSDS → my Rosjects…, same error above. …,

Please fix ASAP, as I need to build a Moveit package in simulation,

Hello @wai.mak ,

Which ROS version are you using for the rosject? You can also share your rosject here so that we can have a look.

@albertoezquerro , version is ROS Melodic,

here is the link Learn Robotics from Zero - Robotics & ROS Online Courses

please advice… I’m still unable to build moveit package for the robot…with same error…

any updates please? (this is really bothering me…)

Hello @wai.mak ,

I’ve been doing some tests with your rosject but couldn’t solve the error or figure out why it’s happening. I could though make it work by changing the rosject configuration to ROS Noetic (which makes me think that it might some kind of error in the Melodic configuration?). You will need to also compile and source the catkin_ws before running the assistant:

cd ~/catkin_ws
source devel/setup.bash

@albertoezquerro , ok in that case, how can I change the configuration of the my ROSJECT to Noetic? …I dont see or find any options on the ROSJECT to change that…,

Please advice,

In The Construct webpage, if you go to the My Rosjects section:

Captura de pantalla 2021-09-03 a las 9.49.44

You will have a list of all your rosjects. Now, If you click on the rosject miniature, it will open the rosject page. Here, you can click on the pencil icon in order to edit its configuration:

On this edit page, you can change the ROS distro of the rosject.

1 Like

@albertoezquerro , ok cool, that is very handy thanks

Hi @albertoezquerro , All,

I was back to kinetic for the moment , are you able to help with the errors Im getting from moveit,

I was trying to do some planning from the current start state to a random valid goal state

and when I clicked on plan button, I get all these errors below…and stuck…

screenshot of My ROSJECT and also error below, please help, thks

Hi @albertoezquerro , All,

any updates on this one above please? I’m really stuck till tonight…, I need directions and advice on how I can get those arms moving…,

@albertoezquerro , All,

Any updates , suggestions please?

Please try to make your rosject work with Noetic as @albertoezquerro already mentioned that he was able to do.

@bayodesegun well in Kinetic, I can at least generate the collisions in Moveit setup (second tab)…(but getting errors above)

In Noetic, yes I can load the URDF but it does “NOT” generate any collisions at ALL in Moveit setup (second tab)…,
it seems it does “Not” recognize the collisions at all, so when I tried to move it in simulation using demo.launch, all the collisions errors comes up…

And now…I cant EVEN get into my rosject to paste some screenshots here which I’m trying to show you the issue I’m facing…, super frustrating… waited more than an hour…, I still cant get in…,

Also, I tried Chrome Firefox, different pc , still could not load my ROSJECT…it is super slow!!! loading ages again… please fix this one asap

@albertoezquerro @bayodesegun , in Noetic, I’m trying to generate Collision Matrix for a URDF in Moveit and it failed to do so, … please advice…, I’m stuck on this for more than a week…,

To demonstrate the issue:

  1. I loaded the URDF

2.Clicked on second tab Self Collision and then clicked on Generate Collision Matrix

and it comes out blank (but in Kinetic …, atleast, it generates the collisions in columns)

  1. And these are the errors it generated…

link to my rosject: Learn Robotics from Zero - Robotics & ROS Online Courses

Hi @wai.mak,

Unfortunately, our schedule is very tight at the moment so we might not be able to support you as much as you want. Our priority is for issues related directly to the courses; we support personal rosjects as far as we can.

We might be able to get some time this week to take a look again. In the meantime, please try to progress as far as you can.

Hi @bayodesegun ,

Understand, … yes it would be great if you can get some time this week to take a look at it…,
Im not trying to reinvent the wheel or anything…I just want to apply what I learnt from your courses to my personal rosjects…, and it’s stuck not going anywhere,

thanks for your reply and I will be “waiting” and looking forward to you coming back with something,

@bayodesegun , did you have some time to take a look?

Hi @bayodesegun , did you have some time to take a look?

Hello @wai.mak ,

The warning messages you show in point 3 are indicating that the URDF file of your robot does not contain correct <collision> tags. Have a look at the definition of the links of the robot (the <collision> tag) and make sure that they are correct.

Hi @albertoezquerro ,

I fixed that problem and not got to do with the collision tags,
anyway, I’m now facing another set of errors, (gazebo loads the robot fine) but stuck on loading RVIZ, and I think it has got to do with the errors, can you please help with your expertise? I’m trying to apply what I have learnt from your courses but still stuck on my robot,

After creating a moveit package and launched : roslaunch inmoov_moveit_config demo_gazebo.launch

errors below:

gazebo loads ok:

and RVIZ just stuck in initialising,

inmoov git hub url:

Hello @wai.mak ,

Looks like an error related to the controllers. Check that the controllers file (probably controllers.yaml or ros_controllers.yaml) is correct.

Hi @albertoezquerro ,

thanks for the suggestions and this is the link to my moveit package (Dropbox - inmoov6_moveit_config - Simplify your life) done as the same way I learnt from the ROS robot manipulation course to create the moveit package,

can you please point me to more specific direction on what I need to tweak or change in the controllers.yaml and ros_controllers.yaml? I m scratching my head on what is wrong in there…
and I only can see “ros_controllers.yaml” inside the moveit package…

Can you share here the output of your rostopic list command?