My teleop_keyboard has something wrong

The angular speed is set to zero automatically.

When I press button D, the angular speed should go negative. If I release button D, the angular speed should remain. However, the angular speed returns to zero as soon as I release button D. The same problem remains on button A. The buttons W and S work fine for now. I can only move forward and backward, but I cannot turn!

I have checked that nothing except telop_keyboard is publishing \cmd_vel.


Are you moving it with the keys “i” , “j” , “l”, “.” ?
Could you elaborate with asmall video or something that we might see whats the issue here?

Unfortunately, these keys are not working.

It seems that there exists another key source on your cloud system.

The following snapshot is captured from my local virtual machine. (Can you see the picture? Your system does not allow me to upload figure in a reply, I have to use another server.)

After I run the teleop_keyboard, it will stop at the interface shown in the snapshot. Every time I press a key, it pops up a line of message

‘currently: linear velocity 0.0 angular velocity 0.0.’

However, the message is continually popping up on your cloud system. It seems like someone is pulling the keyboard all the time.

I tried to use the command apt-get to reinstall the teleop_keyboard, but certainly, it will not work. However, worthy to try.