No shown map in canvas in the web page

hi everybody
i followed all steps for the exercice of the unity 7, but it not shown anythind in the canvas, i don´t have any error in the console.

Please, i need helpe i have tried resolve this for days and do not can’t resolve.

1 Like

Hello @jlcarrillo67,

Let’s find out where the problem is!
Could you share your html and js files, please?
I need to reproduce the problem you are facing in order to provide a solution!


Thanks for answering
I used the same files provides for the course in the final of unit 7, i can’t upload files for here.


Hi @jlcarrillo67,

There are many possible causes for not having the streaming working. If you can’t upload the files, could you send me an e-mail with more details?


I have send you the files on email, please help with the problem.

same problem in ROSDS and on my local machine, I can plot a map with this command :

rosrun map_server map_server /home/map/my_map/map.pgm 0.05

but it’s only static… if I launch the node gmaping :

I got a plot but only at the start, then no update…

Hello @pierredesreumaux,

Let’s try to debug it deeper. Please, launch rviz and check if the map shown there is updated

The map widget should have the same behavior.


Thanks, I have tried to launch rviz in the same time, nothing more yet… same if I try to echo the topic /map nothing seems to be publish on that.

Hello @pierredesreumaux,

Thanks for the detailed report. I have noticed the simulation was wrong and I just changed it.
The problem is that mapping was expecting laser scan to come from /scan, which is published by Husky robot, not by Turtlebot 2.

Sorry for the inconvenience, let me know if I can help with something else.

Please check a demonstration attached as GIF I’ve got the same issue, is this something I need to do in the code or is it already fixed on your side?


Could you please post your issue as a separate topic, giving more details? It’s been a long time since the initial issue, and a lot of things have changed.